Sign in to follow this  
5625tom

Aygo Heater Blower Only Works On Full.....

Recommended Posts

Hi there,

Does anybody out there have any ideas why my heater blower only works on full? The first 3 levels have just stopped working and i have no idea how or why.

Thanks in advance for any info/responses!

Cheers

Tom

Share this post


Link to post
Share on other sites

More than likely it is the heater resister that has failed. It will be working on full speed as you say. The reason for this is that on full speed the heater fan is working at full Battery voltage and any speeds lower pass through the resister effectively reducing the voltage to the motor in stages dictated by the switch position. Not sure where it is located on the Aygo but it it is probably on the heater box somewhere. This is a reasonably common issue on many makes of car so don't feel that it is just an Aygo issue. Another thig to look out for is signs of heat damage to where the connector plug on the wiring loom connects to the resister. Hope I have been of help.

Share this post


Link to post
Share on other sites

Normaly it sits in the tube from the heatherfan to al exits and than near the the heatherfan , a few weeks a go a replact one from my sister in law's starlet for € 5 from a scrapyard. Now it works fine again

Share this post


Link to post
Share on other sites

Evening guys, really appreciate your response, i'll have a look into it, cheers

t

Share this post


Link to post
Share on other sites

I hope you can access it decently: on the Starlet the blower probably was on the pasengerside above the footwell,

in the Aygo the blower sits in the middle of the console, behind the radio and AFAIK can only be accessed from

the side, so between the pedals (or behind the glovebox, depending on LHD or RHD...)

Share this post


Link to post
Share on other sites

Hi,

Just had a look at it to be honest i wasn't sure what i was looking for :)

I went down to my local garage who said they couldn't quote me for doing the job as they couldn't confirm how long it would take to remove the whole dashboard. (they couldn't locate the resistor) They said that the part costs £27 and they would book it in initially for a days work at £300 but might need more time= more money! might try another garage!

cheers

t

Share this post


Link to post
Share on other sites

Looks like the blower is on the oposite side of the center console compared to the aircon filter. My aircon filter is on the passenger side and that means my blower is on the driver side of the centre console. If we could remove the part of the dash above the driver's footwell, the blower should be accessible. Or, just taking out the radio you may get your hand at the resistor since it sits on top of the blower from the diagram.

Share this post


Link to post
Share on other sites

Same issue here. If you search youtube for Aygo radio removal you will see how to remove the whole of the centre panel which should give access to the top of blower unit. No more than 2 minutes work.

Share this post


Link to post
Share on other sites

Cool, cheers guys - ill have a butchers!

Share this post


Link to post
Share on other sites

Took the radio out today, dash out to get to the rheostat I'm afraid.

Share this post


Link to post
Share on other sites

let us know how it goes and take some pictures while taking out the dash, which screws/bolts etc before you reach the fan and the resistor.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this