Sign in to follow this  
thatch

Wiring Loom

Recommended Posts

I have a 2002 avensis d4d...i noticed 2 spare electrical plugs hanging beside each other near the window washer bottle...between the engine and the water bottle. They can only be seen when you take off the fog light blank from the bumper and look in and up. Would these be for plugging in fog lights? Just curious...thanks for replies.

Share this post


Link to post
Share on other sites

I'm not entirely sure but you find in most cars since the 90's that they fitted the same loom to all spec of models,,cheaper and easier than making a different loom for each different model specification.

My guess would be it is for fog lights.

Is there a similar connector on the passenger side behind the fog light cover,,if so then almost certainly it's for the fog lights !!

Share this post


Link to post
Share on other sites

I since discovered cables on both sides for the fog lights. They plug straight into the lamps no problem. I changed the indicator stalk for one with the front fog switch on it. The fuse is there and ok but they still don't work. When i turn on the lights and the rear fog lights i can hear all the relays working but i hear no relay when i turn on the front fog light switch and no light on the dash. I looked at all the fuse boxes but cant see where the relay would go or maybe its a shared relay. Just frustrating they wont work when plugged in and all! If the wiring is there at the bumper for them surely the rest of the car would be set up for them? Thanks...

Paddy...

Share this post


Link to post
Share on other sites

It doesn't look like the front fog lamps are pre wired as Toyota do an accessory kit for Avensis without fr fogs and it includes wiring and a separate switch to make it fit.

Check here http://www.toyota-tech.eu/aimuploads/%7BA972D00E-3025-4567-80B7-B2667BC66BB2%7D/Front%20foglamp%20set%20%20PZ417-T0511-00.pdf

Share this post


Link to post
Share on other sites

That's a great pdf very detailed! My car already has the wiring at the bumper for the fog lights so i would only guess that the rest of the car is wired. It could be that i just have to add a relay somewhere. But using that pdf i must check and see if there are wires in the same position on my car...thanks

Share this post


Link to post
Share on other sites

Finally got my fog lights working! Tested the cables for power at the bumper and they had power so removed the fog lights. Turned out to be bad connectors on the fog light units...wee repair job and all is working great! So the car is pre wired for front fog lights. All that's needed is the fog lights, indicator stalk and relay...many thanks for the help guys.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this