Jump to content
Do Not Sell My Personal Information


Avensis Front Fog Lamps


Recommended Posts

Hi guys...i have a 2002 avensis d4d gs which i am fitting front fogs to. I have found the wiring is already at the bumper and have plugged in the lamps. I changed the indicator stalk for one with a front fog light switch on it. The fuse is ok in the fuse box but they don't work. When i switch on all the lights and rear fog light i can hear all the relays but i hear no relay when i turn on the front fog light switch and no light comes on the dash. I don't see on the car where the relay could go. Is it possible that the car is only partially pre wired for fog lights? Any help would be great thanks...

Paddy...

Link to post
Share on other sites

Hi, I am trying to put fog lights on my 2001 avensis with exactly the same problem. Got a new stalk that had what looked to be an extra relay attached but the front lights still dont work? Any ideas?

Thanks

Link to post
Share on other sites

I still have not got my lights wired up yet! The cable is at the bumper and i too changed the stalk but not working. It would appear that you have to add a relay beside the fuse box under the dashboard and probably some wiring but where to wire it to i just don't know. It could be that they have to be wired via a separate switch to a new relay but i'm not very technical so i can't be sure. The other option is to wire them up yourself. There are loads of universal pre wired fog light kits on ebay. It would just mean feeding the wiring around the car and using a separate switch but you would need to know what your doing or you could fry the car!

Take a look at the following pdf..it goes into great detail if you can follow it! sorry can't be of more help at this stage..

http://www.toyota-tech.eu/aimuploads/%7BA972D00E-3025-4567-80B7-B2667BC66BB2%7D/Front%20foglamp%20set%20%20PZ417-T0511-00.pdf

Link to post
Share on other sites

To date I changed the indicator stalk and installed the fog lamps on the bumper. I put a relay under the dash...these is a place for it to plug into. When I turn on the fog light switch the light comes on the dash and I can hear the relay click but still no lights. I'm thinkin maybe there is another relay or fuse or link wire somewhere...I thought it would be easier than this!

Link to post
Share on other sites

Finally got my fog lights working! Tested the cables for power at the bumper and they had power so removed the fog lights. Turned out to be bad connectors on the fog light units...wee repair job and all is working great! So the car is pre wired for front fog lights. All that's needed is the fog lights, indicator stalk and relay...many thanks for the help guys.

Link to post
Share on other sites

  • 7 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership