Sign in to follow this  
aygo_uk

2013 Yaris Breakdown

Recommended Posts

Hi

Wondering if anyone can shed some light on my issue?

I have a 2012 yaris petrol. Twice recently I have parked up for about. 20 minutes after driving and the gone to start again but it won't start. The yaris makes a whirring almost like its blowing a raspberry. The dash lights come on and flutter. I can also hearing a ticking sound. After about 30 minutes it will start again.

Any ideas please?

Thanks

James

Share this post


Link to post
Share on other sites

Sounds rather like a bad Battery or bad connection - except for the 20 minutes bit.

But even that could be down to a heat thing, which might suggest Battery rather than connection.

You could drive it to a garage and get them to load test the Battery while it's all still warm which might show a problem up.

Share this post


Link to post
Share on other sites

Sound like a job for the supplying dealer to sort out under warranty :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this