Sign in to follow this  
Adrian.ldn

Toyota Avensis 2.2 D4D Diesel Engine Stalling At Start-Up

Recommended Posts

Hello,

I am new here and I would like find out more about an issue with my avensis 2.2 D4D Diesel 2005 .

The problem is that last thursday when I left from work, after a while driving, the dashboard lighted up and the engine stopped. I couldn`t manage to start it up afterwards and I had to use a booster from a garage near by to start it up. As soon as we started it we did a Battery test and a charging test also and it showed that the alternator wasn`t charging. After a few minutes I stopped it and when I tried to start it again didn`t want to and it would have run only if I kept my hand on the key in the ignition because as soon as I released the key the engine would cut off. I managed to get hold of a brand new alternator and changed it on friday. Tried to start it again but nothing..the same thing - as soon as it turns and try to throttle it it dies. Changed also the ignition switch but nothing. Please advise

Share this post


Link to post
Share on other sites

I gave this advice a couple of times before and so providing the engine is actually turning over ok ... Clutch IN ... NO throttle and start the car .... don't touch the throttle until the engine speed picks up itself, you may have a faulty MAF or temp sensor but just see if this works first.

Pete.

Share this post


Link to post
Share on other sites

Thanks Pete I saw the posts before but wanted to explain my own problem as it is. Just had a diagnosis computer on it and it gives the error P 020 injector open circuit but nothing related to the MAF sensor. The thing is that I didn`t felt any changes recently in the engine running (no noises or unusual running). I will try to clean the sensor tomorrow or maybe I will be able to find another one to swap them to see if there is any change.

Share this post


Link to post
Share on other sites

Hi Adrian,

have you fixed your problem???

I have same problem, mechanic told me to change the fuel pump , possibly driver injector and alternator. looking for 1000 pounds so far.

please replay :ermm:

Share this post


Link to post
Share on other sites

Ive got the same sort of problem ..anyone got any ideas im pulling my hair out and dont know weathe ti go to main dealer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this