Sign in to follow this  
pulkit1990

2012 Yaris Engine Rattle?

Recommended Posts

Hi,

I have the 2012 yaris, its only done 2000 miles and I noticed yesterday that there was a strange rattle coming from the engine when it was cold. The noise went when it heated up.

Not heard this noise before... What could it be?

Share this post


Link to post
Share on other sites

Quite possibly the auxilliary drivebelt. Were weather conditions wet/damp at the time? Could you only hear it at idle? If you increased the revs to 2000rpm (ish) did it go away?

Timing chains can rattle on older cars but yours is new!

Share this post


Link to post
Share on other sites

The weather was not really wet or damp. I could hear it when idle and it got louder as I revs increased. It went away after 5-10 mins of driving.

Share this post


Link to post
Share on other sites

Quite possibly the auxilliary drivebelt. Were weather conditions wet/damp at the time? Could you only hear it at idle? If you increased the revs to 2000rpm (ish) did it go away?

Timing chains can rattle on older cars but yours is new!

Out of curiosity, is the auxiliary belt meant to do that or does it mean there's a problem with it?

Share this post


Link to post
Share on other sites

Hi,

I have the 2012 yaris, its only done 2000 miles and I noticed yesterday that there was a strange rattle coming from the engine when it was cold. The noise went when it heated up.

Not heard this noise before... What could it be?

2012 model. Surely the dealer is the first port of call. Could be the purge solenoid valve or simply the injectors

Regards Geoff Peace.

Share this post


Link to post
Share on other sites

Quite possibly the auxilliary drivebelt. Were weather conditions wet/damp at the time? Could you only hear it at idle? If you increased the revs to 2000rpm (ish) did it go away?

Timing chains can rattle on older cars but yours is new!

Out of curiosity, is the auxiliary belt meant to do that or does it mean there's a problem with it?

Drive belts do not rattle, they may squeal and squeak if they slip, or the pulleys may rattle if they are loose.

Regards Geoff Peace.

Share this post


Link to post
Share on other sites

Hi and welcome to TOC!

Is your Yaris the 1.0ltr? If so then it could be the timing chain as I have experienced this on a low mileage 3 cylinder Yaris when the temperature was below zero and just like you describe, it disappears after a few minutes when the engine warms up a little.

If your's isn't the 1.0 then I'm sorry I've been of little help!

Share this post


Link to post
Share on other sites

Quite possibly the auxilliary drivebelt. Were weather conditions wet/damp at the time? Could you only hear it at idle? If you increased the revs to 2000rpm (ish) did it go away?

Timing chains can rattle on older cars but yours is new!

Out of curiosity, is the auxiliary belt meant to do that or does it mean there's a problem with it?

Well they're not designed to squeak/chirp/flutter, but they can do when they're cold. I had new belts put on mine a year ago but they soon began to chirp again when cold. Many many cars do it, as I can evidence in my work car park at home time on a cold damp day!

Share this post


Link to post
Share on other sites

Quite possibly the auxilliary drivebelt. Were weather conditions wet/damp at the time? Could you only hear it at idle? If you increased the revs to 2000rpm (ish) did it go away?

Timing chains can rattle on older cars but yours is new!

Out of curiosity, is the auxiliary belt meant to do that or does it mean there's a problem with it?

Well they're not designed to squeak/chirp/flutter, but they can do when they're cold. I had new belts put on mine a year ago but they soon began to chirp again when cold. Many many cars do it, as I can evidence in my work car park at home time on a cold damp day!

If a belt chirps, squeaks, squeals or makes any other noise then something is wrong. It may be a cheap belt where the cross section profile is wrong, it may be glazed, incorrectly tensioned, the pulleys may be out of line, the alternator or water pump may be partially seized etc. The fault should be found and remedied before it gives serious trouble. All too often sound of this nature are ignored, the consequences are sometimes serious and costly.

Regards Geoff Peace

Share this post


Link to post
Share on other sites

No need to overreact!

No cheap belts. Genuine Toyota ones fitted by Toyota mechanics. It's just the way these cars are. And if they're glazed already then blame Toyota. You may have a point but if you ask a mechanic to check all those things you know he'll just laugh when you're back's turned and fit some new belts.

Share this post


Link to post
Share on other sites

No need to overreact!

No cheap belts. Genuine Toyota ones fitted by Toyota mechanics. It's just the way these cars are. And if they're glazed already then blame Toyota. You may have a point but if you ask a mechanic to check all those things you know he'll just laugh when you're back's turned and fit some new belts.

No overreaction. Just fact. As I said, if any belt is noisy, there is a reason, which should be found before it causes further trouble. Most mechanics these days are simply fitters they do not, and in all probability cannot, work from first principles. I have seen many instances of new belts being fitted, in some cases repeatedly, when the cause of the noise lies elswhere. My wife has a new model Yaris, I assure you the belt runs silently. The original post concerned a 2012 car! Why should anyone tolerate a noisy belt on a new car? The remit is simple, find the cause and remedy it. Never be satisfied with second best, and never accept the stock phrase 'They all do that'

Regards Geoff Peace.

Share this post


Link to post
Share on other sites

Thanks for you advice everyone, Ill take it back to the dealer tomorrow and have them look at it.

Share this post


Link to post
Share on other sites

Well I took the car in for to get checked out and it turns out that the cause is piston slap (I presume). Toyota has asked me to leave the car with them for some time so they can change the pistons in the engine.

Glad to get this sorted out.

Share this post


Link to post
Share on other sites

WHOAH! Wasn't expecting that on a 2012 car! That's very strange but fair play to them for taking it in for remedial work.

What engine does yours have?

Share this post


Link to post
Share on other sites

Mine is the 1.33 multi drive.

Share this post


Link to post
Share on other sites

So what exactly does this noise sound like? Glad to hear you're getting it sorted :)

  • Like 1

Share this post


Link to post
Share on other sites

It sounds like it is the drive belt, although they only usually make chirping noises after 10-12k miles. Ask your technician (mechanic then) to change it. This should be done under warranty and if your dealer is any good they will do it for you.

John

Share this post


Link to post
Share on other sites

It's a carbon build up on the head and piston slap, mine has it a 4.5K and is waiting to be done. Sounds like a proper little end rattle

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

It's a carbon build up on the head and piston slap, mine has it a 4.5K and is waiting to be done. Sounds like a proper little end rattle

Kingo :thumbsup:

Forgive me but I do not understand this at all. Piston slap on a new engine? carbon build up on the head at 4,500 miles? What on earth is going on? Tolerances these days are much less than say even twenty years ago and we have piston slap on a new engine. Just what are Toyota thinking about? new pistons in old bores! or are they wet liners? in which case they should be renewed. It does not bear thinking about. I believe the 1.33 engine has been around since 2009. Surely plenty of time for faults such as this to rear their ugly heads. I would be insisting on a new engine for a new car, not a rebuilt one. No short cuts!

Regards Geoff Peace.

Share this post


Link to post
Share on other sites

Well I took the car in for to get checked out and it turns out that the cause is piston slap (I presume). Toyota has asked me to leave the car with them for some time so they can change the pistons in the engine.

Glad to get this sorted out.

Just to be clear piston slap is what a mechanic friend of mine has said it sounds like not officially what toyota have said. After checking online it sounded the same to also which is why I have said "I presume".

However I agree that this sort of thing shouldn't happen with a new car. I'm just glad to have it sorted without having to pay for it ;)

Share this post


Link to post
Share on other sites

I dread to think what's caused it. By the sound of it, it's related to cars with the Multidrive CVT system? Maybe the engines are being too restrained with this transmission?

I have a Yaris 1.33 (mk 2 XP90 model) with the 6 speed manual and it doesn't have this issue. As Geoff Pearce pointed out, this engine has been around since 2009 with very few faults reported (if any).

Share this post


Link to post
Share on other sites

Forgive me but I do not understand this at all. Piston slap on a new engine? carbon build up on the head at 4,500 miles? What on earth is going on? Tolerances these days are much less than say even twenty years ago and we have piston slap on a new engine. Just what are Toyota thinking about? new pistons in old bores! or are they wet liners? in which case they should be renewed. It does not bear thinking about. I believe the 1.33 engine has been around since 2009. Surely plenty of time for faults such as this to rear their ugly heads. I would be insisting on a new engine for a new car, not a rebuilt one. No short cuts!

Kingo :thumbsup:

Regards Geoff Peace.

Sorry, that was a very quick reply and not entirely accurate

There was a production change to the camshaft bearing cap and pistons, this was to prevent carbon build up in the combustion chamber, resulting in a "hammering effect" and therefore noise a bit like piston slap (or rattle)

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

Forgive me but I do not understand this at all. Piston slap on a new engine? carbon build up on the head at 4,500 miles? What on earth is going on? Tolerances these days are much less than say even twenty years ago and we have piston slap on a new engine. Just what are Toyota thinking about? new pistons in old bores! or are they wet liners? in which case they should be renewed. It does not bear thinking about. I believe the 1.33 engine has been around since 2009. Surely plenty of time for faults such as this to rear their ugly heads. I would be insisting on a new engine for a new car, not a rebuilt one. No short cuts!

Kingo :thumbsup:

Regards Geoff Peace.

Sorry, that was a very quick reply and not entirely accurate

There was a production change to the camshaft bearing cap and pistons, this was to prevent carbon build up in the combustion chamber, resulting in a "hammering effect" and therefore noise a bit like piston slap (or rattle)

Kingo :thumbsup:

So nothing to worry about then? Were some of the previous 1.33's getting carbon build up?

Share this post


Link to post
Share on other sites

Forgive me but I do not understand this at all. Piston slap on a new engine? carbon build up on the head at 4,500 miles? What on earth is going on? Tolerances these days are much less than say even twenty years ago and we have piston slap on a new engine. Just what are Toyota thinking about? new pistons in old bores! or are they wet liners? in which case they should be renewed. It does not bear thinking about. I believe the 1.33 engine has been around since 2009. Surely plenty of time for faults such as this to rear their ugly heads. I would be insisting on a new engine for a new car, not a rebuilt one. No short cuts!

Kingo :thumbsup:

Regards Geoff Peace.

Sorry, that was a very quick reply and not entirely accurate

There was a production change to the camshaft bearing cap and pistons, this was to prevent carbon build up in the combustion chamber, resulting in a "hammering effect" and therefore noise a bit like piston slap (or rattle)

Kingo :thumbsup:

So nothing to worry about then? Were some of the previous 1.33's getting carbon build up?

Good question Lorna 2. If the engine was suffering from carbon build up it may be down to urban use and short runs. However, if this build up is the case and there is excessive carbon on the piston crowns there is every likelihood that it will also be present in other places such as the back of the inlet valves, egr valve etc. Let us hope someone is able to clarify the position.

Regards Geoff Peace.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this