simonhmoss

Sat Nav Update Removes Uk Postcodes

Recommended Posts

Got a call from local dealer and car is booked in for next week. They said leave it for day because they've not had to do this before. They're supplying a courtesy car, free of charge. Hats off to Toyota for quick responses today.

Share this post


Link to post
Share on other sites
 

Good news. Sat Nav now updated to the latest version with full post code entry. Toyota had to order the update on usb stick and the engineer confirmed that there seems to be a problem with the update downloaded via the portal being different from the version they have despite having exactly the same ID. This is apparently being worked on so hopefully future updates will be OK (although I will check with Toyota before applying). Free updates are apparently only available via the portal otherwise it's £30 for the memory stick.

Share this post


Link to post
Share on other sites

Just got back from the dealer. Toyota had sent out a USB stick over night which once loaded seems to resume full post code search. Interestingly its the same version of software (ending 019) that was previously loaded. However it not the same version of software as the speed warning announcement has changed from "you are above the speed limit" to "the speed limit is X mph). My destinations and apps also seem to have been retained. The speed limit is still at the bottom right of the screen, before the update two weeks ago it was always at the top right hand corner of the display. The question is, when do we connect to the portal again?

Share this post


Link to post
Share on other sites

The dealer fixed the issue today, software 2.7.4H, map EUH20121019. So full 7 digit postcode. Supplied me with a free courtesy car and gave my car a wash. Can't fault Toyota service and response once they admitted there was an issue. Since they appear to know there's an issue with downloading from the portal, I would hope they would be addressing this for future updates.

Share this post


Link to post
Share on other sites

Like a mug, I today paid for, and downloaded the new map for my Mrs Yaris HST Touch & Go from the portal - and hey presto, I now have only 5-digit postcode entry.

Phoned up Toyota Customer Services who were about as obtuse as it gets - just told me to go to my dealer to have it looked at. No acknowledgement that there is a known issue.

So they still haven't fixed the update to ensure this doesn't happen :-(

Share this post


Link to post
Share on other sites

Hopefully this thread gives you the ammunition to get them to update it to 7-digit at no additional cost.

Share this post


Link to post
Share on other sites

Full postcode OK here, as in AANN NAA which is 8 digits including the space.

This is after updating earlier this year using USB stick.

Quite a troublesome process with having to try the process out on three different computers, lots of trial and error involved - but eventually got what appears to be a July 2012 map edition installed on the car that was bought in July 2012. Previous map edition was mid-2011. The map upgrade was free.

The new 2012 map is not fully upto date - shows out of date road layout and speed limits in the Walsall area.

Even out of date by quite a margin in mid-2012.

Share this post


Link to post
Share on other sites

Had a phone call from Toyota and evidently, the Toyota Technical department "didn't think there was an issue with the update for the Yaris Touch & Go"on the portal - apparently it requires a new 'license key' and firmware to be loaded at the dealer. You'd have thought they would have tested the update before releasing it, and I wonder how many people have installed it and just accepted that is how it works now.

I have also noticed that a few roads around our home, the speed warning/reminder on the display disappears - always the same road and in the same place, so I assume that these roads do not have a speed limit associated with them which is another fault or bug, as they used to work fine with the old software/map.

Just awaiting the promised call from the dealer to get it booked in. If they cannot fix it, I'll be demanding a replacement nav unit under warranty.

Share this post


Link to post
Share on other sites

Really grateful for this thread. Registered on the portal and did and upgrade early April. Then realised that postcode input had changed several days later when my partner complained about being unable to create new destinations with a full postcode.

Google brought me to this thread and so I checked for further upgrades on the portal. Upgraded again on May 8th and the problem was solved - full UK postcode input reinstated!

The upgrade took only a few minutes so presumably it only corrected the 'error' in the navigation software.

Map version stayed the same.

version is: 2.7.4H and map: EUH20121019

Share this post


Link to post
Share on other sites

Yeah, Toyota fixed the 'H' version of the software but evidently the 'L' version such as in the Yaris didn't get sorted. Whether it is now is anyones guess, and I'm not going to touch the portal again until I get assurances that the issue is fixed.

My car is booked into the dealers next week, and the service manager reckons they need to update both the system firmware and the map license/map software.

I have also noticed with this newer map that the speed limit indications are not present on SOME roads around our home. Basically the speed sign will just disappear and no speed warnings will be given. Always comes and goes at exactly the same point on the same roads, so it looks like the data is missing from the mapping. Pretty poor show really as it was there on the 2011 version of the map. Anyone else noticed this?

Share this post


Link to post
Share on other sites

7-digit postcode entry has been restored after a trip to the dealer and a 1:30 wait. So good news on that front.

However, the missing speed limit notification/overspeed warning is still there - so this is definitely a map data issue that Toyota are going to have to address, as the old 2011 map had the data, but the 2012 map doesn't. A bit crap really.

Share this post


Link to post
Share on other sites

I'm taking delivery of a Auris Hybrid late 2001 model on Friday. When taking a test drive the salesman demo'd the sat nav and I noticed the partial post code entry. After finding these forums it appears that the software needs changing. I've send links but they're adamant that it's fine! Quote - There are numerous Toyota navigation systems on the market so I think that the owners clubs will be referring to a different system.

The later Auris cars come with the Toyota touch system which do use postcode lookup.

Hope this clarifies things.

Can anyone clarify if that makes any sense? If I have to go back to get it sorted after telling them I'll not be a happy bunny.

Share this post


Link to post
Share on other sites

I believe that the system you are getting is the same as mine (Nov 2011) which is the same as was in the Gen 2 Prius. This doesn't support full postcode entry and no software exists to resolve this, it is something that you learn to live with. I rarely use postcodes as it is so problamatical only being able to use 5 characters so either use the address or the map - sometimes I find somewhere near and then use the map to find the point I want. Once you have things stored it is less of an issue, until you change your car, as I did, and have to start again !.

I hope this helps, the system being talked about in this thread is the touch system which has a different update method. The system in the 2011 mode is updated by a set of DVD's which aren't cheap.

Peter

Share this post


Link to post
Share on other sites

Sorry Paul, another thought. Did you ask them to change the reverse warning beep from continuos to a single beep ?. Worth asking them before you collect it to preserve your sanity !

Share this post


Link to post
Share on other sites

I believe that the system you are getting is the same as mine (Nov 2011) which is the same as was in the Gen 2 Prius. This doesn't support full postcode entry and no software exists to resolve this, it is something that you learn to live with. I rarely use postcodes as it is so problamatical only being able to use 5 characters so either use the address or the map - sometimes I find somewhere near and then use the map to find the point I want. Once you have things stored it is less of an issue, until you change your car, as I did, and have to start again !.

I hope this helps, the system being talked about in this thread is the touch system which has a different update method. The system in the 2011 mode is updated by a set of DVD's which aren't cheap.

Peter

Thanks Peter, that makes more sense now. Amazing how a ridiculously expensive system isn't as good as a free phone app.

Share this post


Link to post
Share on other sites

I don't know your car at all, so please forgive me if I am taking you down a blind alley.

On my 2009 Gen 3 Prius, the satnav system can easily give the impression that it does not support full postcode entry. If you use only the first page of the satnav display and go in through the address route, when you get to the postcode element it will not take a full postcode.

However there is a second page of the display available which is entered by using the tab marked "1/2" on the first page.

The second page offers a direct postcode option without using any other address details and this option allows a full postcode entry.

I just wondered whether yours might have something similar.

Apologies if I have been wasting your time.

Share this post


Link to post
Share on other sites

I don't know your car at all, so please forgive me if I am taking you down a blind alley.

On my 2009 Gen 3 Prius, the satnav system can easily give the impression that it does not support full postcode entry. If you use only the first page of the satnav display and go in through the address route, when you get to the postcode element it will not take a full postcode.

However there is a second page of the display available which is entered by using the tab marked "1/2" on the first page.

The second page offers a direct postcode option without using any other address details and this option allows a full postcode entry.

I just wondered whether yours might have something similar.

Apologies if I have been wasting your time.

Not at all - thanks for the info - I get it Friday and will investigate.

Share this post


Link to post
Share on other sites

Confirming what Sagita has posted, my Prius T Spirit purchased July 2013 has the option of post code input when you select destination/address/town but only allows a four digit entry after which it asks you for a street name which is useless. But on the second page there is a UK Post Code option which allows full post code entry. I assume the first post code entry dialogue box must be aimed at Continental post codes or something. The manual of course is written in ancient Klingon so isn't terribly clear on this point.

Share this post


Link to post
Share on other sites

Another possible confusion is that the 'space' character on the keyboard is actually the ',_,' underscore char (bottom right corner )

Had me puzzled trying to enter a standard UK postcode, until I found the ',_,' spacebar.

Regards,

G...

Share this post


Link to post
Share on other sites

I've a 2013 Prius Plus T4 with the optional Touch & Go plus/satnav. I've only had it four weeks so far and haven't used all the menus as I've been used to voice commands on previous cars so have just been trying to learn how to drive the satnav via voice. So far I've not found a way to enter a postcode (either 4 digit or full) via voice and as I'm in the habit of scrawling down a postcode on a post-it before I set out I'm left struggling to enter my destination as I've usually forgotten (or never knew) the road name etc. Does anyone know if entering a postcode via voice can be done?

Share this post


Link to post
Share on other sites

I tried to use voice to enter post codes and on hearing "Post Code" it repeated "Fast Food" and gave me list of MacDonalds, Wimpeys etc. So no, it probably doesn't accept post codes via voice.

My Sat Nav does however accept new destinations when on the move and in the middle of an existing route - no lockout here it seems. Also by pressing NAV for the navigation screen and the separate NAVI button plus HUD you get head-up-displays of turns, roundabouts, motorway junctions etc. which I thought, judging by some of the comments, it didn't do. After the junction or whatever has passed, it changes back to showing the speed on the HUD.

The other useful but puzzling output (not on Sat Nav screen) happens if you have have previously put in the fuel cost per gallon. At the end of your journey you turn everything off as usual by pressing in the main Power button. For a short while it displays (on the upper screen next to the mpg and speedometer) a summary screen showing the mpg, miles travelled and cost of the journey since you last started the car up. Then the display disappears forever after about 30 seconds. I wonder if you can retrieve this information.

Share this post


Link to post
Share on other sites

Hi Cirsium, can you just run through how you get the HUD to display sat nav arrows again in a bit more detail. Mine is a "plus" so might be different but I don't recal having a separate NAVI button. The main buttons either side of the touch screen include a map/nav button and the only HUD button is to the right of the steering wheel?

Share this post


Link to post
Share on other sites

I finally got around to upgrading the Touch and Go Plus software and map installed in my 2012 Gen3 Prius TSpirit (2013 model - the latest variant with LED running lights).

Please dont confuse this with the 2010 Gen3 (which I have also owned). Same shape, no running lights and different (dual screen) navigation system. I so miss this dual screen system.

What a palava!

I have been experiencing lots of routing (and rerouting) errors with the car being shown hundreds of yards off track and sent in circles (especially around Kingston upon Thames!). And the system was soooo sloooow. Apparently the latest software fixes this (according to my local garage).

My software was 1.7.9H and map update EUH20120611. The unit accepted 7 digit post code and there isnt a 'second page' (that was in the 2010 hard disk gen 3 car :))

Following proceedure I took a USB 'signature' from my car and then accessed the Toyota Touch and Go application.

Immediatly i received a message that there was an urgent update which I had to install onto the USB.

Confusingly, the application also offered a 2012 Q4 map update (and also told me I had already installed this?). However, I decided to download this new map version and install it in my car.

After the usual hour of installation (a good way to pass the time during a journey down the M40 today), I received the huge surprise that the software and map version is now 2.8.4H and EUH20130409.

And there are map differences....

I took another signature and retried the T&G application to be told yet again that there is an urgent update, further navigation update and updates to a couple of the free apps. I put the USB in the car again and it updated but strangly, didnt cause any change to software or map versions.

Ok so what has changed?

Its much faster and I am pleased to report that the 7 digit post code is intact. Entry of the post code is also much faster and predictive - more so than before. The map colours have changed and there is also a junction image which can be turned off - not sure if this existed in the old version - if it did I never used it.

However, the 3D mapping is now awfull. The angle of 'view' is too shallow, meaning that as you zoom in, it becomes impossible to distinguish roads, and the top 10mm of the screen is taken up by a blue horizon - does absolutly nothing except waste screen real estate. Changing from 3d to 2d and back is going to be a necessary pain.

One improvement I noticed is that routing now automatically bypasses slow traffic. My route to the office is down the M40, M25 and M4. The previous system always routed down the M25 and M4 and only then rerouted due to slow traffic.

However the new system didnt even try to go down the M25 (there was 20mph traffic this morning!). I will monitor this on future trips.

Russ

Share this post


Link to post
Share on other sites

Thanks for the update Aimhigh. I've put off updating the SatNav on my 2013 T-Spirit following the horror stories earlier in this post. However, I decided I may as well give it a whirl...... (I last updated the map about a year or so when the car was brand new).

So far it has proved to be a disaster..... not the maps - I haven't got that far yet. No - just the simple process of getting the data onto my USB stick.

After 3 hours, I'm currently 4% through the download..... and the USB has been dismounted 3 times.....

The software is pants. (technical term for "not very good").

Each time the USB gets dismounted (why does this happen???) it restarts (great!) but then says that "something has changed on the USB so it must be refreshed from the car"...... Strange,... as far as I can see, nothing has changed on the USB stick.

So.... at this rate, it is likely to be some time next month before the download completes.

I'll keep you all posted.

Share this post


Link to post
Share on other sites

Hi Dave R
I agree, the method of updating maps is truly pants!

Sounds like you are having lots of 'fun'. Is this the first step -- getting the 'signature' data from your car? If so it sounds like a loose connection. Have your tried another USB stick.

If its the second step on your PC then it could be the usb system on your pc - due to the time it takes to download the data with continual writes to the usb stick...maybe try on another pc??

Good Luck.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...