Sign in to follow this  
mark_le_b

Help,changed Ecu To Cure Gearshift - But Now Immobilised!?

Recommended Posts

Hi

As a follow on from a recent thread regarding ecu/gearshift issues, I've just had a new ECU from ECU testing ltd which I've just put in the car.

But now it won't start! It turns over - but little red immobiliser light is flashing, so I assume car is immobilised?

Stuck now - and clues? I was hoping it was "plug n play" type of thing, just swap over the ecu and away we go - but it seems not!

Any suggestions welcome.

Thanks

Mark.

Share this post


Link to post
Share on other sites

Try pressing and holding both lock and unlock buttons on the key fob until the indicators answer back.

Share this post


Link to post
Share on other sites

Try pressing and holding both lock and unlock buttons on the key fob until the indicators answer back.

Hi

Not sure what answer back is - but pushed both but its done nothing I'm afraid.

I had the Battery on charge whilst ECU was out of car if that makes a difference?

Thanks

Share this post


Link to post
Share on other sites

Has the code frm the key gone out of sink with the ecu ? Just a Thort ....

Share this post


Link to post
Share on other sites

Has the code frm the key gone out of sink with the ecu ? Just a Thort ....

Hi

That's exactly it I guess as I've changed the ECU out and also the Battery - so I guess out of sync means immobilised - I just need to know if that's a DIY fix, or, if dealer has to do it (neither key will start the car)

Cheers

Share this post


Link to post
Share on other sites

Hi

As a follow on from a recent thread regarding ecu/gearshift issues, I've just had a new ECU from ECU testing ltd which I've just put in the car.

But now it won't start! It turns over - but little red immobiliser light is flashing, so I assume car is immobilised?

Stuck now - and clues? I was hoping it was "plug n play" type of thing, just swap over the ecu and away we go - but it seems not!

Any suggestions welcome.

Thanks

Mark.

Anybody any thoughts?

I'd happily disconnect the immobiliser if anyone has instructions on how to do it, as I'm sure thats the problem.

failing that will have to tow to dealer :-(

Thanks

Share this post


Link to post
Share on other sites

How long did you press and hold both buttons?

Share this post


Link to post
Share on other sites

How long did you press and hold both buttons?

Hi

A minute or more......

Share this post


Link to post
Share on other sites

OK, then I think I would phone the ECU guys.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this