Sign in to follow this  
ajaz

Toyota Avensis 1998 Model Not Starting When Hot

Recommended Posts

hi everyone,i have a Toyota avensis 1998 model and I have problems starting it when it gets hot! no problem when cold, I have took it to several mechanics but cant find a problem. I have changed the crank sensor but no luck! the diagnostics showing crank sensor..so I put a brand new one in! the car turns over put doesn't seem to fire up, there is spark I have checked.

Share this post


Link to post
Share on other sites

I know your problem I've had myself its a weak starter-motor , I had mine change four years ago no problems since then.

Share this post


Link to post
Share on other sites

hi dog7, thanks for your reply! I was thinking about putting a new starter motor but still not sure because when the car is hot,the starter motor is turning but does not fire up! so what do you say,is it still the starter motor...

Share this post


Link to post
Share on other sites

Hello .Ajaz, mine was the same as yours it would turnover but not fast enough to start the engine. The d4d diesel needs a good kick to start when hot.

Share this post


Link to post
Share on other sites

Same problem on the 2.2 D4D. Got a new starter all was good after.

Share this post


Link to post
Share on other sites

hi guys! I will try putting a new starter motor, will let you know the outcome! by the way mines a petrol engine, don't think that will make a difference. I was doing some research online and someone said they had the same problem with their ford vehicle and they changed the main relay I think or the fuel relay and problem solved..so I'm a bit baffled.. lol..

Share this post


Link to post
Share on other sites

It could be the starter motor relay, or the fuel pump circuit.

How are the HT leads? They tend to break down when hot.

The only thing you can do is to check and clean any connections.

Share this post


Link to post
Share on other sites

hi guys,since I have put this topic on Toyota forum the car has not yet give me problems with starting yet! so thumbs up at moment..

Share this post


Link to post
Share on other sites

Glad to hear that.

Share this post


Link to post
Share on other sites

Wow, truly the internet is a powerful thing! Lol

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this