Sign in to follow this  
Treebeast

Rav4Xt3 Problems

Recommended Posts

Hi,i am a newbie here with a 2003 rav4 that i love to bits.Recentley she has been sluggish to start,turning over longer than she should and eventually blowing the main 80 amp fuse at the Battery.After checking glow plugs,relays etc and having an auto electrician check it i am still at a loss.We are about to check out the fuel system thinking that maybe the fuel is running back.It may be worth mentioning that even when the engine is hot after a good run it is still sluggish in starting.power seems fine when travelling.If anyone can help i would be very appreciative as i dont want to sell.

Share this post


Link to post
Share on other sites

Start by changing the earth lead from the Battery to the chassis and the engine. Something is causing it to draw to much current when it is cranking.

Share this post


Link to post
Share on other sites

If they are the originals it might be worth renewing the glow plugs, for what they cost.

I had a similar problem on my old jeep,the plugs seemed to test ok,but changed 'em anyway and bingo!

Although it usually only effects cold starting.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this