Sign in to follow this  
samosa

Air Con Problems

Recommended Posts

I need some advice on my air-con.

my aircon was blowing warm air so i took it kwik-fit to regas. when i got into my car it was as cold as a fridge and lasted like this for approx 9 days.

I returned to kwik-fit who said they would hook it up to the machine to see whats up, they said they only recovered a third of the gas and it must have a leak somewhere, they've regassed it and gave me a refund.

Additional info:

When i turn my AC on, the light is on constantly and the system does blow some cold air but not like it was after leaving kwik-fit. No grinding noises can be heard from within or outside the cabin.

I am sure the AC engages as i notice my RPM jump from 700 to around 900.

I suffer from hayfever and want to avoid driving with the windows open but am hoping it's not an expensive to job to rectify the fault.

has anyone experienced any of these symptom or give me a rough guess as to what could be faulty.

And can anyone recommend an AC repairier around the London Area or SE Region.

All help will be greatly appreciated.

Share this post


Link to post
Share on other sites

just had a specialist round, who said i need a new condenser.

doesn anyone know how much it cost from Toyota or should i just go with Eurocarparts/GSF?

Share this post


Link to post
Share on other sites

its only a radiator , any will do , id imagine Toyota will want mortgage money for it tbh .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this