Sign in to follow this  
T078igers

Corolla T Sport Radio Display

Recommended Posts

Hi folks, I have recently bought a corolla t sport and noticed the radio display that shows mpg, av speed etc shows some very erratic numbers. Been using it a week current mpg seems not to work at times, I reset av speed then did a 5 mile dual carriageway journey and it showed 8mph and av mpg is about 12. Also this display seems to flash intermittently.

Anyone else have these issues or offer any advice?

Share this post


Link to post
Share on other sites

Hi,

The MPG Ave does seems to stay steady once you have done say over 10/20 miles, while the other do fluctuate quiet quickly.

If its flashing as you say, I would perhaps suspect there might be a poor connection to the unit, its quiet probable that the original Toyota head unit has been refitted after the previous owner took out his fancy audio unit that many owners fit as the Toyota one is not the best in the world.

Think pics of the removal of the unit is covered in the Stickies above or in the Audio section

Share this post


Link to post
Share on other sites

Hi

Admittedly i read your thread a few days back, and it made me monitor my readings today, which i noticed seem to literally flash all sorts of random figures, like its going mad, but then i have removed my unit a zillion times so its possible as oldcodger states that something or some wire may have possibly have had enough, but i never look at it anyway so i aint to botherd! :driving: . The fact that my boot light has never worked bothers me more lol!!! :disgust:

Share this post


Link to post
Share on other sites

Thanks for the replies. How do you remove the stereo? Does it come out with the air vents as one unit or just on it's own?

Share this post


Link to post
Share on other sites

HI...

If you forum it you will loads on the topic...maybe even illustrated photographs for a step by step...but basically...

You remove your gear trim surround (pull it up gently all round)...unscrew your gear knob...then simply pull on your fascia/console form the very bottom upwards...disconnect all wiring...you'll see 4 bolts to undo that are holding your stereo...and then gently with some side to side action pull out whole vent unit...you can then unclip your radio from the vent surround...and that's it!!! And oh don't forget to disconnect your Battery, I never have done and nothings gone wrong for me, but its only right that I mention it as its better to be safe than sorry!

Cheerio :football:

Share this post


Link to post
Share on other sites

.......and if you haven't already bust your dash board, you need to pull of the centre fan speed switch where you will find a solitary screw lurking!

Share this post


Link to post
Share on other sites

.......and if you haven't already bust your dash board, you need to pull of the centre fan speed switch where you will find a solitary screw lurking!

I'm a little confused here as I certainly don't remember seeing a centre fan speed switch that has a screw????

I did forget to add after I mentioned "and then gently with some side to side action pull out the whole vent unit"...you'll then need to disconnect all wiring to the rear of the stock stereo!!! And then unclip radio from vent surround!

And I can't see why someone would bust their dash board trying to remove their stock radio??? I've removed mine a number of times and broke nothing, nor scratched a thing, nor warped anything, if anything the unit sat better than before! Ie...the famous gap spaces due to a design fault or installation at Toyota!!!

:gora:

Share this post


Link to post
Share on other sites

Have a look at this from about 2.00 mins. Mine is exactly the same but maybe your screw is missing if you'll pardon the expression!

Share this post


Link to post
Share on other sites

Have a look at this from about 2.00 mins. Mine is exactly the same but maybe your screw is missing if you'll pardon the expression!

OH I understand the misunderstanding now...you've got the manual dials and I have the electronic...duh...sorry...we should have clarified that from the start! :ermm:

Share this post


Link to post
Share on other sites

OK, you might be right if he has the auto too. I never considered that batgirl.

Share this post


Link to post
Share on other sites

Just get rid its hopeless anyway. I am constantly in lift and in traffic and apparantly i always avg. 37mpg?? Its a little optimistic I think. Which is why im replacing it with an xtrons td720. I will put a little guide up once ive done it cos apparantly they stick out a bit. However no matter what it wont look like someone from toyota has thrown a cd player somewhere in the general direction of the dash. The gaps and creakiness is appauling!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this