Sign in to follow this  
Silver_Fern

Rav4.2 Manual Stalling At Low Revs - Ecu Or Electrical Issue?

Recommended Posts

Hi All,

We have problems with our 2000 RAV4.2/MK2, which appear to be related to power to the ECU. We have a very good independent mechanic who has spent hours trying to diaognose the fault, with the help from the local main dealer, but we are getting to the point where we either need to spend some serious money throwing parts at it, or very sadly look at selling it as a non-runner.

I have seen issues with the transmission and ECU on Automatic vechicles, but this is a Manual Petrol model (1AZ-FE). I have spent hours looking at forums and have not seen any faults that look similar.

Prior to the Fault: The car had been sluggish and the feul economy had been bad for some time. The car had been converted to LPG a few years ago and despite a new lamba sensor (for a recorded fault) the engine management light gets triggered occasionally by the LPG, so remains on until reset. Hence the engine management light had been on continiously as normal. The plugs fitted are "hotter" plugs specially designed for LPG vehicles. The car had been serviced about a month ago with Oil change and new air filter fitted. A couple of weeks before the fault we went on a long trip and noticed that after several hours of highway driving when we would stop the engine and try to restart it 5mins later it would struggle to start and would take alot of cranking before it would finally fire. Once it fired it would be OK and would run fine. There was no difference in trying to start on LPG (engine was hot) or Petrol, so this was not fuel related.

The Fault: Initally occured when my wife was driving. Not long after starting (2mins) the car lost power and bucked a little before picking back up. At this stage the car was cold and only 1/4 mile into the journey. Less than a mile after starting the car stalled. My wife restarted but the car would keep stalling after 10 seconds, she would then keep restarting and reving until she managed to get to somewhere she could stop. I came to meet her and tried starting and got the same result - the car would start but then run very rough and miss, and you would need to keep revs to over 3000 or so to stop it dying - even then it would regularly miss and then die. The EML was flashing very quickly when it was missing, but not staying on constantly. The AA came out and struggled to get any codes out of the ECU but eventually managed to get a PO301 - Cylnder No1 Misfire. There was no difference between running on Petrol or LPG so again, not fuel related.

The car was recovered to my mechanic who struggled to run diagnostics. When hooking up to the machine, when it would miss and die the diagnostic machine would loose connection to the ECU (drop the feed). He tried another more advanced diosnostic machine with the same result - it dropped the feed.

The Air Mass sensor was dirty so this was replaced and he took the car for a test drive and it ran fine. I then picked up the car and it ran fine all the way home (10 miles) without skipping a beat. About 20mins later (engine still would have been warm) I took the car down the road and got about a mile down the road before it stalled. I restarted it and had to keep it at high revs all the way home. It was behaving the same as before, although the car did stall less than before, as long as you kept the revs up. I tried to drive it to the mechanic the next day but got less than 1/4 of a mile before the car stalled and kept stalling. I had to again get it recovered to the mechanic!

According to him there is an underlying pulse (this has been measured), but the theory is that there is some kind of power supply type issue meaning that the ECU power unit is either losing power or it keeps resetting itself.

The coils are not in great condition, but he does not think that this is the issue (especially as it seems to be intermittent), and a coil pack is about £400 for four, so we dont want to replace them if this is not the issue. The plugs are in OK condition, the throttle body looks OK (although has not been cleaned) and as above the air mass sensor has been replaced. The mechanics of the engine have been checked and all seem OK.

The reason that we think that it is an ECU or electrical issue with power to the ECU is that the diognositc machines keep loosing their feed when the fault occurs, and no fault codes are being stored (almost like it is a pre-ECU fault). The main dealer has been helping and cant find the issue either - even the toyota diognostic machine lost its feed when the fault occured (so thats three different machines)!

I contacted the Brooklyn Boys (chkengine via their website) and their response was:

"Hi. It does not look like ECM problem. At least it is not common problem and could not be repaired without having whole car at our place.
If you suspect ECM, the best way to confirm or rule it out is to get a used ECM and see if it makes any difference. If you need an advice how to deal with immobilizer I can give you instructions.
The same story you might have if you have corroded ground circuits or defective ignition coil which can knock out ECM. Check ground points on the back of intake manifold and from Battery to car body and engine/transmission block. Makes sense to buy or borrow one ignition coil and switch it one by one on all 4 cylinders. "
I would really like to know if anyone has had a similar hard to diagnose issue with their 4.2 and what they did to resolve it? I am really hesitant to keep throwing good money after bad and cant afford to just throw parts at it, but we love our RAV and really dont want to give up on it!
Thanks in advance for ANY advise you can give!!

Share this post


Link to post
Share on other sites

I probably should mention that the initial mis-fire is thought to be a symptom of the fault, and not the actual fault

Share this post


Link to post
Share on other sites

Definitely clean the throttle body next, mine had a similar problem with low revs stalling at junctions etc.

Gave the throttle body a really good clean and all was well again.

Phil

  • Like 1

Share this post


Link to post
Share on other sites

Definitely clean the throttle body next, mine had a similar problem with low revs stalling at junctions etc.

Gave the throttle body a really good clean and all was well again.

Phil

Thanks Phil - sounds like this is the next thing to try. Did you experience any flashing of the engine management light when this happened?

I have managed to find some info below which would indicate that the flashing of the light may be as a result of a >10% variance in the reading from the crankshaft sensor (i.e. a percieved missfire):

http://www.justanswer.com/toyota/6461r-rav4-engine-codes-read-300-somethings-misfire.html

Share this post


Link to post
Share on other sites

I would try a bottle of injector cleaner through it. I've had miraculous results with it in the past.

  • Like 1

Share this post


Link to post
Share on other sites

I have experienced very similar symptoms on a Mazda MX5. Sometimes ran fine but other times it would start ok then either stall and refuse to start or started but not all cylinders firing. No fault code showed up. Coils on that model are a known weakness but experts suggested coil would either work or not rather than be an intermittent fault.

After changing a few sensors with no joy I eventually replaced the coil pack and it has been perfect ever since. Decision was made easier for me due to it being a known issue.....dont know if there is any history of coils being a problem on petrol Ravs? Just a thought.

  • Like 1

Share this post


Link to post
Share on other sites

Hey mate, any chance you got to the bottom of it? seems I have a the exact same issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this