Sign in to follow this  
9tiger9

Caravanning With A Rav 4 D4D 2.2

Recommended Posts

Anyone out the towing a caravan with the 2.2 rav4 2006-2009. Just had the caravan (2010 elddis ) on the back for the first time and soon as i hitched it up it blew the car's side light/rear light 10 amp fuse in the passenger foorwell. Its not fitted with a Toyota bar as at £600+ asking price fitted it sadly was out of reach, but it has been fitted with a good quality bar by a reputable company. Everything else works fine from the 13 pin plug. Anyone else had any fuse issues whilst towing ( which it does well i must say).

Steve

Share this post


Link to post
Share on other sites

No problem with mine blowing fuses, I have a Westfalia with dedicated wiring harness.

Did the people fitting yours use scotch locks?

Share this post


Link to post
Share on other sites

ours tows very well, I fitted an anchor tow bar I got of flea bay and soldered the connection into the harness in the left side of the boot, I ran another wire to the right hand side under the plastic but for the life of me I can't remember what for, flasher I think? but to blow the fuse I would look for an earth in your wiring

B-A

Share this post


Link to post
Share on other sites

I have been towing with mine for 3 years now and not had one problem. As you say a superb tow car.

I think it best that take it back to the fitters and ask them to check it out.

Share this post


Link to post
Share on other sites

Fuses don't just blow for no good reason so I would assume something has either not been wired correctly or there is a fault with the van

Take the car and van back to the tow bar specialist and have them check it over

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

We have a Witter detachable with dedicated wiring from Towequipe, no problems ,as everyone says, superb towcar, we are down in Alsace at the moment, with a Bailey Ranger GT60 460/4 tows like a dream!

Share this post


Link to post
Share on other sites

Thanks to all for the replies please keep them coming.

I have had a look at the connectors the fitter has used and they are similar to scotchlocks which he has used in the past but these have a gel capsule surrounding sealing them, the fitter says they are an American development and new to the uk and has never had any problems with them and has done loads of Rav 4's over the last 6 years never fitted a dedicated wiring kit to one of them. Tomorrow i will try disconnecting pin 5 then 7 one at a time to try to isolate the fault, then work my way back to the 13 pin socket. till i find something. The indicators and brake lights work fine as do all the other internal functions. The caravan lights only work out at about 2.6 amps( 30 watts/12V), the car 1.8 amp so something is sucking some juice? As pin 3 is communal earth for the brake/indicators which are fine, the plug/socket is brand new so the problem has got to be somewhere in line 5 or 7 on the van. Shoved a 7N pin adapter into the 13 pin and hooked up my mates Compass van to my rav and all was ok, so i think that proves the tow bar electrics are ok.

Share this post


Link to post
Share on other sites

Been towing a 1500kg Elddis with mine for 6 years from new, superb tower. PCT detachable towbar fitted by Towtal with twin N and S sockets. Not had a problem electrics wise at all.

When you tried your mates with an adaptor did you use both the N and S plugs to check it out? the S shouldn't have a bearing on it but with electrickery you never know, the 13 pin is new as you say but that's not to say it hasn't got a fault/short in it.

Share this post


Link to post
Share on other sites

Success!!!! Disconnected black wire from caravan plug as down to earth, found a connector for 13 pin wiring under a cover at the rear of main circuit breaker under bed in van separated 13 pin plug, tested black lead with wiring now in 2 halves. Front half ok went to back and back still down to earth, so some progress. Went back into caravan and found a small beige connector buried under a mound of wiring which had a black/white/brown leads comming out of it also out of back half of 13 core cable, split it and retested both ends for earth fault.......clear, reconnected black wire into 13 pin plug refitted fuse to car and YE HA light alround the van with the exception of the l/h high level marker lamp. Took the bulb out disconnected the black lead hanging clear of the van and tested the black wire............ down to earth the damn thing is still there, short term remedy as wifes shouting for dinner, leave plug separated. But at least i can sort this one at my leisure and not loose too much sleep over 1 missing lamp for the time being. Why dont caravan wiring diagrams look like they do in the book, it would be so easy, and service departments would not ask you to wait 4 weeks to have a look for you at an astounding £52.00 an hour!!!!!!!!!!!!!!!!!!!!! Hmmm mental note to ones self, must get me a job servicing caravans. Hope someone else might benefit from my experiences over the last few days.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this