Sign in to follow this  
winelight

O2 / Maf Sensor, Fuel Trim Fault Finding

Recommended Posts

I have "P0171 Fuel trim too lean (bank 1)".

Inspection of the live data reads:

MAF sensor reading - steady (I believe this means the MAF sensor is probably working OK and does not need cleaning?)

O2 sensor reading - fluctuates between about 0.1V and 0.7V (I believe this is normal operation at idle)?

So, I am stuck to know what to do next?

1. Clean MAF sensor anyway (this seems to be a sensible idea, because it won't cost anything)

2. Replace MAF sensor

3. Replace inlet manifold gasket

4. Replace O2 sensor

5. Replace CAT convertor

6. Something I haven't though of.

Any suggestions please?

Share this post


Link to post
Share on other sites

OK, I cleaned the MAF sensor wires with carb cleaner and it solved that problem.

Share this post


Link to post
Share on other sites

where abouts is the maf sensor located. ive got a friends aygo with the exact same problem and fault code

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this