Sign in to follow this  
mokhali

Squealing Noise When Turbo Kicks In

Recommended Posts

Hi guys need help here, i have an Avensis 2002 2 litre d4d. I had a timing belt water pump with tensioners, Aux belt and alternator belt replaced nearly 1000 miles ago. I now have discovered there is a metalic squealing noise at around 1700 or 1800 rpm upwards when the turbo kicks in and goes away when its below that number. I am assuming its from the turbo but not sure. The performance and fuel consumption is same. And the noise is still there when i rev it at stand still. The car has covered 125k miles.

I want to know if my turbo is on its way and what other signs i could look for.

Share this post


Link to post
Share on other sites

It could be something as simple as the new aux belt requires tightening up, the noise you describe could be a slipping belt

Always look for the simple things first, check the belt tension

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

thanks m8 I will check that and post back with the results.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this