Sign in to follow this  
yaris781

Weird Heater Issue

Recommended Posts

Hi

The mrs Rav we've noticed that its taking its time for the heater to get hot. Usually the temp needle has to move slightly and it's literally very hot. Tbe last few days it gets hot when the gauge reaches the 9 o'clock position and before that its like warm. We've checked coolant levels they are all good and the pipes from the radiator are hot to the touch, the bottom one is cold though.

Any ideas what it could possibly be as would really want to get it sorted before winter sets in.

Any help, advice always appreciTed

Thanks👍

Share this post


Link to post
Share on other sites

An engine that is slow to heat would normally be the thermostat stuck in the OPEN position. This allows water to bypass the stat and therefore take longer to warm up, I would try that first

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

Thanks for that John!! Will give it a go over weekend.

👍👍

Share this post


Link to post
Share on other sites

It does not need to be stuck open very much, just a small opening is enough to make it take ages to get warm

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this