Sign in to follow this  
230868hpj

E11 Electrical Fault?

Recommended Posts

Hi All,

Looked int he forum but can't find any posts that are similar to what I am currently experiencing with my 199 plate E11 corolla.

When I turn the ignition the speedo and rev counter needles both deflect to the maximum then return to the start point. the internal light no longer works neither does the radio/cd player.

All this started to happen yesterday ? I have no idea why ? Does anyone have similar experiences ? Could it be an electrical fault or fuse problem?

Thanks for any pointers or guidance!

Share this post


Link to post
Share on other sites

Just an update incase anyone experiences something similar. Took the Battery off and trickle charged it. Put it back on and everything is fine.

Not sure if the Battery needed charging or just a poor connection but hey-ho car is working fine now. Touch wood.

Share this post


Link to post
Share on other sites

Hi,

Or possibly disconnecting the Battery Reset various things so clearing the fault ...?

You might find tickover from cold is a bit irratic until the ecu relearns.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this