Sign in to follow this  
kennydal

Windscreen Washers.......again

Recommended Posts

Hi, I have a 57 yaris and the front winscreen washers only skoosh the water onto the bottom 2 inches of the windscreen. The motor is operating and I have replaced both nozzles but it still only sprays the water onto the bottom of the screen. Any ideas?

Share this post


Link to post
Share on other sites

Does your Yaris have the non-adjustable washer nozzles? For the Auris, the 0 degree angle jets are fitted as standard and you can get -2 degree, +2 degree and +3 degree angle jets - see http://www.toyotaownersclub.com/forums/topic/88310-washer-jets/?hl=+windscreen++washer

Share this post


Link to post
Share on other sites

Hi Frostyballs, it has the non adjustable ones.

Share this post


Link to post
Share on other sites

What, can you not do the old jam-a-pin-into-the-nozzle-and-wiggle-it-around trick?

Share this post


Link to post
Share on other sites

I've changed the nozzles, they are brand new! I am thinking that the motor has lost power or something.

Share this post


Link to post
Share on other sites

As you've changed the nozzles, have you gone for the same degree angle jet or have you gone for a + degree angle?

Share this post


Link to post
Share on other sites

Check to see if the windscreen washer tube leading to the nozzles is not kinked, that's what happened to me once, the kink slows the flow of water through the tube

Share this post


Link to post
Share on other sites

Frostyballs, I didn't know you could buy the nozzles with different angles. I'll investigate that but it looks more like there isn't enough power to push the water any further up the windscreen. I'll have a look today to see if S M Smith's suggestion could be correct.

Share this post


Link to post
Share on other sites

The nozzles are angled, so if you bought some of the Zero or +1 then it will spray at the bottom of the screen. That said, the pump could be weak causing a low pressure, or one of the return valves could be blocked

Take the pipe OFF the nozzle and spray it, see what happens, you should be able to tell if it has enough wooomph pushing the water out

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

Ok folks, thanks for your replies. The hoses are not kinked and I've tried changing the nozzles all to no avail. Anything else is outwith my limited technical capabilities.................The garage who sold me it are taking it back for repair. thanks again.

Share this post


Link to post
Share on other sites

I have seen a few cars where the "Y" piece that splits the single feed to each of the jets has a non return valve which has failed this causes a flow restriction

Valve is part # 85321-0D010

Washer jet +1 # 85381-52280

Washer jet +2 # 85381-52300

Share this post


Link to post
Share on other sites

Thanks Lee. car is going back to garage on Monday. Hopefully they will fix it this time!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this