Sign in to follow this  
avensisd4d786

Rear Wiper Constantly On 2004 Avensis & Temp Gauge Has Dropped&#33

Recommended Posts

My rear wiper wont stop wiping until ignition is off.

When on the OFF position on the stalk the wiper is still wiping also have noticed the average mpg and range are blank and the temp gauge is all of the at the bottom.

when putting the wiper on the ON position the temp gauge goes to its normal position also the range and the mpg are back.

I am thinking that rear wiper motor is at fault. anyone come across this?

any advice?

I did get the car washed a hour before this started to happen.

Share this post


Link to post
Share on other sites

The T22 had a similar fault due to water getting into the wiper motor down the spindle but I don't remember it affecting to guages, just disconnect the wiper motor at the back of the car see if the fault clears if yes then remove it, strip it down and look inside for water ingress which can short out the contacts which control the auto park of the wiper arm.

Pete.

Share this post


Link to post
Share on other sites

The T22 had a similar fault due to water getting into the wiper motor down the spindle but I don't remember it affecting to guages, just disconnect the wiper motor at the back of the car see if the fault clears if yes then remove it, strip it down and look inside for water ingress which can short out the contacts which control the auto park of the wiper arm.

Pete.

Thanks Pete.

That is what I am going to do on Saturday, was too dark to do anything tonight, and I am working till late tomorrow. Just the fuel gauge has got me slightly worried. but like I say, if I put the wiper ON, fuel gauge is ok.

from what I have researched; the back panel on the tailgate, has two screws and 12 clips? then the motor has 3 bolts holding it in, not forgetting to remove the wiper arm and nut.

Share this post


Link to post
Share on other sites

The motor is easy to remove and there is a driven disc with brass segments to reverse the motor. My motor drive was full of water and hardened grease and showed the same fault as yours (but without the gauges thing). I cleaned up the disc, coated it in petroleum jelly and it was then fine-rather better than £145 from Mr T!

Share this post


Link to post
Share on other sites

The T22 had a similar fault due to water getting into the wiper motor down the spindle but I don't remember it affecting to guages, just disconnect the wiper motor at the back of the car see if the fault clears if yes then remove it, strip it down and look inside for water ingress which can short out the contacts which control the auto park of the wiper arm.

Pete.

The motor is easy to remove and there is a driven disc with brass segments to reverse the motor. My motor drive was full of water and hardened grease and showed the same fault as yours (but without the gauges thing). I cleaned up the disc, coated it in petroleum jelly and it was then fine-rather better than £145 from Mr T!

all cleaned and greased!

has been back in for the last two days, working fine, surprisingly temp gauge working too! to be honest it feels like its working better than before but that may be physiological!

so its a result, I also decided to price the wiper motor from Mr T and it was £150+.

£3.99 electrical contact cleaner spray from Halfords did the trick.

  • Like 1

Share this post


Link to post
Share on other sites

The T22 had a similar fault due to water getting into the wiper motor down the spindle but I don't remember it affecting to guages, just disconnect the wiper motor at the back of the car see if the fault clears if yes then remove it, strip it down and look inside for water ingress which can short out the contacts which control the auto park of the wiper arm.

Pete.

The motor is easy to remove and there is a driven disc with brass segments to reverse the motor. My motor drive was full of water and hardened grease and showed the same fault as yours (but without the gauges thing). I cleaned up the disc, coated it in petroleum jelly and it was then fine-rather better than £145 from Mr T!

all cleaned and greased!

has been back in for the last two days, working fine, surprisingly temp gauge working too! to be honest it feels like its working better than before but that may be physiological!

so its a result, I also decided to price the wiper motor from Mr T and it was £150+.

£3.99 electrical contact cleaner spray from Halfords did the trick.

Very good mate but don't forget to include the small fee to Sproutdreamer and Pete :-)))))) the two Cheshire lads.

  • Like 1

Share this post


Link to post
Share on other sites

As you saved so much money you should invest £15.00 in an annual membership ;)

http://www.toyotaownersclub.com/forums/store/product/3-toc-supporter-club-membership/

TOC SUPPORTER MEMBERSHIP, for a minimal fee the TOC Supporter member will enjoy unlimited access to the forums and a magical feeling of warmth for contributing towards, and being a part of an exclusive club.

TOC Supporter Member (£15.00 per year)

*Unlimited access to post within all of our public forums
*Access to our supporter moderation free forum
*Larger PM storage box from 100 to 5000 PM messages
* Ability to upload files/images into forum posts (10 meg)
* Ability to upload pictures into the gallery
* Can start new polls within Forums
* Subscribed Member recognition in forum posts
* Use of our Buy & Sell section (private sellers only... no traders please)
* Customise your profile
* Club Sticker
* A warm and comforting glow from knowing that you are not only a member of an exclusive club - but that you are also actively contributing to the success of the club.

Share this post


Link to post
Share on other sites

started playing up again. have ordered a new rubber grommet 85143-05050 hopefully this will be stop the water ingress.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this