Sign in to follow this  
lovegroove

4.2 D4D, What Happens At 2250Rpm In 5Th?

Recommended Posts

I've got a strange problem of being limited to 2500rpm in 5th gear. It revs fine all the way through 1st and 2nd, then limits power at 3000rpm in 3rd, 2500rpm in 4th and 2250rpm in 5th.

I'm thinking maybe turbo issues, but hoping it's something cheaper like SCV. My fuel consumption has jumped massively as well. Not what I needed just before Christmas!

Cheers for any suggestions.

Share this post


Link to post
Share on other sites

It could be many things but before getting too involved - replace the fuel filter. Is the engine warning lamp illuminated?

Share this post


Link to post
Share on other sites

I replaced the fuel filter already and I've had the EGR off and given it a clean. Tried a tank of decent diesel and even some additive to see if that improves things, but it didn't.

Last week before I changed the fuel filter I had a warning light and the code was something like fuel pump control, but I can't remember the exact code, maybe something like 6027. The guy at the garage thought it might have been the fuel filter, so that's why I changed it first.

Don't really have the time or money to go back to the garage at the moment as i need my car for work.

Share this post


Link to post
Share on other sites

Code 6027 isn't valid and it's probably 0627. This code is usually associated with the SCV valves and matches the type of symptoms experienced - you might coax them into working but the long term remedy is to replace the valves. Double check the retained code first - you can buy a reader for around £10 - cheaper than getting a garage to read the codes.

  • Like 1

Share this post


Link to post
Share on other sites

I'll get the SCV's off this weekend and give them a clean and hit them with 12 volts to see if it makes any difference. The weird thing is that it seems to be worse when the engine is warm. This morning on the way to work it let me get a little more power, so was able to get to 2750rpm in 5th and hit an eye watering 120km/h. On uphills when I need a bit of power it still cuts out below 2000rpm sometimes.

As all the garages in france are now closed until about the middle of january I have to try and sort this out myself and really don't want to have to take my car to mr T.

Share this post


Link to post
Share on other sites

Oh Deep Joy.......you're in that France, where non Frenchies need their bloody passport with them to get a bloody puncture fixed.

Bon chance avec votre problem, min, and Joyeux No Well tae......

Share this post


Link to post
Share on other sites

Anyone ever ordered scv's from alibaba? When I type part number 04221-27011 into google I get links to alibaba to what look like genuine scv's for a toyota. Seems like I could get them for about £100 delivered compared to hearly €300 for them in France.

Share this post


Link to post
Share on other sites

Alibaba McChinese copies......? Be tres careful, mon mucker.....and they WILL be coming from China, in case you don't know, so heck knows what delivery time......?

Share this post


Link to post
Share on other sites

Alibaba is a trade link website and there will be minimum order quantities. Even though the adverts show branded parts - beware of Chinese copies. You'll also need to pay for shipping, VAT, customs duty and clearance charges. For around £170 BIN - theres a set of new genuine Toyota valves on Ebay at the moment!!

http://www.ebay.co.uk/itm/Toyota-Scv-valves-corolla-avensis-rav4-picnic-brand-new-in-toyota-box-Nissan-/121237609133?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item1c3a531aad

Share this post


Link to post
Share on other sites

Looks like the threat of me taking a spanner to my Rav scared it into working for a few days. Today however the problem is worse, with really weird symptoms.

My VSC light came on when I was idling. I now have very little power and it struggles whenever I put my foot down, no matter what speed or gear I'm in or how many revs I'm doing. Sometimes it will suddenly jump into life and will drive like normal for a few miles, then I'll suddenly lose power.

What I find weird is that if it was something like egr or scv stuck then I wouldn't expect the sudden power loss (because if a valve was sticking open or shut why would it suddenly change position) that I'm experiencing. It feels much more like an intermittent electrical problem, but I can't see anything obvious and I've had a poke around with a multimeter.

I don't think it's a fuel supply issue, because when it happens my fuel consumption goes through the roof, presumably something to do wuth the turbo not kicking in? Every garage still shut here in France and very reluctant to take it to mr T because all they do is read the code and tell me I need to change the turbo at a cost of €2000+, without any real investigation.

Merry Christmas everyone!

Share this post


Link to post
Share on other sites

I don't know where you live in France but I can tell you that the garages are opened since yesterday. I live in France as well.

Anyway, I had a similar problem and I went to AD. They fixed it (ie changing the SCV's valves) for much less than Mr T.

Share this post


Link to post
Share on other sites

Are you sure that the fuel you have bought for said RAv is actually diesel and not paraffin ?

Or water soaked ?

Share this post


Link to post
Share on other sites

I am beginning to think that it was a bad tank of fuel. I've since added a bottle of additive to try an clean out the injectors and am on my 3rd tank of fuel since the problem started and things seem to be improving.

The thing that I really can't get my head around is the sudden loss of fuel efficiency when I get the power loss. I can be cruising along at 60 with the instantaneous mpg reading 45 and then just increase speed a tiny amount, get power loss and mpg drops to between 15 and 20 mpg.

Could this be caused by an injector problem where the fuel is pouring in instead of being sprayed or an SCV problem where one of the valves isn't opening to boost fuel pressure and the low fuel pressure is causing the problem? My friend suggested it might be a fuel pump issue as his wife had exactly the same symptoms on her freelander, but again, why the loss of fuel efficiency?

The garages are open again today, but I really need my car this week so I'm going to use it as it doesn't seem to have any problems if I stay below 2500rpm

Share this post


Link to post
Share on other sites

Is the ECU still throwing up code 0627? If so - this would strongly suggest an SCV issue.

Share this post


Link to post
Share on other sites

I'm still having issues with it, but it's a lot better than before. I haven't had any vsc light come on for a while, and it is at least fairly consistent now with losing power at about 2500-2750 rpm in 5th and fuel economy suddenly going through the roof. That should make it easier for the garage to diagnose and fix, I just need to find the time to get it to a garage.

Just wanted to add one more detail to help with online diagnosis by you wise and wonderful Rav 4 folk. When I put my foot down and the problem occurs, when I lift off I get a kind of judder from the engine, like you would get in a petrol car wihen it backfires. It's feels to me like the engine is flooded. The other thing is that I can hear the turbo whistle all the way up to when the problem starts and then it just stops.

WEIRD :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this