Sign in to follow this  
Rabbijon

Wipers

Recommended Posts

Quick bit of advice please. My wipers on the rav have this strange thing where, when you put them on the fastest setting they will go painfully slow, much slower than the normal wipe setting you would put them on. Had issues before with the wipers but corrected itself and just left it. Is the motor needing replaced? Cheers.

Share this post


Link to post
Share on other sites

Maybe try cleaner the motor.

I had this on mine and once I had cleaned it all was well

Share this post


Link to post
Share on other sites

The Rav has a three brush motor - the issue is that the high speed brush is dirty / burnt. Clean up the commutator / brushes and slightly increase the tension on the brush springs.

Share this post


Link to post
Share on other sites

Any tips on the plastic cowling removal so I can access the wiper motor.

Share this post


Link to post
Share on other sites

Mark the wiper positions on the screen with tape - remove the central nut and lift off the wiper arms - move them slightly side to side to free them on the shaft splines. Unclip the rubber finishers which connect the louvre top to the side edges of the windscreen trims. Undo 2 fasteners and around a dozen claw type retainers and lift off the top louvre cover.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this