Sign in to follow this  
stevieg43

Help,

Recommended Posts

Hi,

Im new to this forum and im seeking help, tonight on the way home from work my N/S front light bulb blew low beam, and since this happened I have the red Battery light on and water in fuel warning light on and also the water in the Oil light on too. the alternator also makes a nasty whirring noise has done since I purchased it 2 years ago.

regards

steve

Share this post


Link to post
Share on other sites

Replace the bulb and have the alternator checked, also check for any water ingress due to the extreme weather conditions.

alternator --- > check condition of connections / degrease them; have multi tester and measure charging voltage;

Oil level ---> be sure you have no an Oil drinking issue;

water in fuel filter ----> time to time you should drain fuel sludge from filter housing -- it is normal.

PS, Welcome to the club... Enjoy :driving:

Share this post


Link to post
Share on other sites

had this on an Auris yesterday at work. Was a broken wire coming off the alternator and corrosion on a connector. Once that was fixed all lights went off

Alex

Share this post


Link to post
Share on other sites

Welcome to Toyota Owners Club.

Moved to Avensis club

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this