Sign in to follow this  
justchilin

My 72 Toyota Corona Deluxe

Recommended Posts

Hey everyone, newbie here, just wanted to share and ask a question. I have a 72 Corona Deluxe, all stock. Drives great and looks pretty damn good for its age. I was wondering if you all can help me with a little prob. On 2 occasions now, Ive taken her for a drive around town and the Oil light comes on when at idle at a stop sign. It will slowly dim on and then off and sometimes in between like it wants to come on but doesnt. It all depends on my idle, when I accelerate, its off as well as when in park. Im not sure what Im idling at as my car wasnt made with an idle gauge but its not that low where it feels like it wants to turn off, not at all. There is no other skips, smoke, sounds of anything different when it comes on. Just wondering if this light indicates pressure or level? My Oil level is good, and the only thing I did different this time was go get my Battery recharged as it had died from not driving my car in about a week. Could it be the sensor going bad? Hoping its not the Oil pump...Anywho, Any help would be greatly appreciated. Thanks!

post-137181-0-16815600-1389505971_thumb.

post-137181-0-59521700-1389505976_thumb.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this