Sign in to follow this  
SteC73

Fast Ticking Sound In Cabin?

Recommended Posts

This is weird, but there is a strange fast ticking when the engine is running, but it doesn't sound like its coming from the engine, and the tempo doesn't change when the engine is revved, and you don't need to be moving to hear it?

Anyone got any ideas?

It's an '08 t180

Thanks

Share this post


Link to post
Share on other sites

Something caught in the fan??

Share this post


Link to post
Share on other sites
Guest

Have you changed the cabin pollen filter recently? Or even just checked it? Located behind the glove box

Share this post


Link to post
Share on other sites

Cant see anything on the fan and no haven't looked at pollen filter but that is where the noise is coming from. Gonna have a look now, is it easy to get to and will I see if it needs replacing?

Share this post


Link to post
Share on other sites

Ok that's the pollen filter removed and cleaned (will get a new one as it was covered!) but the noise is still there. With my head in the passenger footwell underneath the glovebox it sounds more electrical, like relay or something going mad?

Share this post


Link to post
Share on other sites

Perhaps something caught in heater fan,can you hear it with engine switched off and blower/heater on.Have had dry leaves caught in inlet before.

Share this post


Link to post
Share on other sites

It was the heater fan I meant,Steve, as some times leaves and other debris can get in there.

To follow the suggestion by Gust on my motor you have to empty the glove box and sqeeze the sides of it so that it can hang down.

there is a white rectangle that then just unclips and then you will have it

Del

Share this post


Link to post
Share on other sites

oops to late

Share this post


Link to post
Share on other sites

Yep, thanks guys, it is something in the heater fan, now, how the hell do I get to that lol?.

Share this post


Link to post
Share on other sites

I see, will take glove box out again lol

Share this post


Link to post
Share on other sites

Sorted, dropped the fan out and sure enough, leaves, leaves, leaves. Nice and quiet for the little lady now!

Thanks alot for your help guys!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this