Sign in to follow this  
JoeyJoe

High Fuel Consumption And P0172 Error.

Recommended Posts

I filled my tank right up, and now I'm at 3 bars (just under quarter tank), and I've only done 175 miles.

When I drove to Scotland and back before this problem, I was reaching nearly 400 miles a tank. So clearly something is amiss!

What would be the first sensors or parts to check or replace? I don't have the money to take it to a specialist garage to hand over a blank cheque at the moment, so looking for things I could try first. Have a brother that knows what he is doing, but doesn't know where to start with the over fueling problem.

Just to mention I have cleared the error code and it comes back within 20 or so miles.

EDIT: Forgot to mention that the car prior to this had a problem with the idle, and cut out when stopping at lights. My brother cleaned out the idle air control valve and that problem went away. Then a week later this new issue.

Share this post


Link to post
Share on other sites

Thanks, I checked the code already and know it's to do with the fuel mixture being too rich.

I'll clean out the MAF sensor tonight. Thanks.

Share this post


Link to post
Share on other sites

I have a 55 plate Toyota Corolla t sport compressor, it keeps failing the not saying the co is to high I believe this is an over fueling problem? Any advice?

Sent from my iPhone using Toyota OC

Share this post


Link to post
Share on other sites

We managed to fix the issue I was having with this error code by taking out the MAF sensor on the front airbox, and absolutely drowned it in brake cleaner. The wires and sensor was black with dirt before hand, and shiney afterwards. The error hasn't come back in 400+ miles.

However, I calculated my MPG yesterday and found I am only getting 25mpg, or ~250 miles to a tank. Could be my driving though :D

Share this post


Link to post
Share on other sites

Jamie, are you getting the same error code?

Share this post


Link to post
Share on other sites

It's just failing the mot on co which iv been told the problem is over fueling, I can't remember the error off the top of my head I'm afraid

Sent from my iPhone using Toyota OC

Share this post


Link to post
Share on other sites

Is the engine management light on on the dash board?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this