Sign in to follow this  
handyandy63

Rav4 Smoking - Help

Recommended Posts

Hi, I’ve had this 2006 Toyota rav 4 t180 2.2 turbo diesel with just over two years it came with a full Toyota service history
A few weeks after its last 60,000 service i noticed a plume of smoke coming from the exhaust and a strong smell of what i can describe as paraffin it’s not there when i start the car it only starts when the engine gets up to normal operating temp and it’s not all the time.

I booked the car in to Toyota and for £96 they said it was the cat and would need a new exhaust and cat that would cost me £1100.
I did get a new exhaust and cat but i had a custom built cat and flow through stainless one for £520 but it made no effect on the smoking problem.

This time i went to a local garage after they looked at the car they said they could not find anything wrong with it compression was good and it was normal to smoke a little.
Still not happy with the car i went back to Toyota who looked at the car for free this time and guess what they checked everything no loss of water or Oil and nothing wrong with the car .Is it something they have missed.

So I’ve now spent £620 and no nearer finding out what’s wrong with the rav and i know it’s not me and there is a problem so hope you guys have some useful advice on this one.

Share this post


Link to post
Share on other sites

Is everything else normal or have there been any other changes that have occurred when the smokey exhaust began, i.e. fuel consumption, Oil consumption, any drop-off in performance, etc?

When the smoking began and the cat was apparently failing, did the EMS light come on in the dash, i.e the little engine light? I had a cat fail on a petrol 4.2 but it caused the EMS to light up. If you have an OBD reader, have you checked if any codes are lodged in the car's system? My experience with Toyota is that they aren't particularly trustworthy when it comes to cat failures - they missed mine completely, instead replacing oxy and exhaust sensors one by one until they realised that the cat was shot.

I don't pretend to be any kind of expert on diesels but have you checked out the EGR valve and the DPF aren't clogging up?

Share this post


Link to post
Share on other sites

Well all seems ok no lights on the dash , Oil level the same as last checked performance ok , water ok, cleaned the EGR a few months ago and it was a bit full but ok , not checked the DPF ill have to find it first .

Share this post


Link to post
Share on other sites

There is a bulletin form Toyota only for cars with DPNR of which your Rav is one that mentions Excessive white smoke from the exhaust, there is some diagnosis to confirm the cause:

Check 5th injector operation

Check for air leaks

Check and calculate MAF operation

Check EGR , EGR cooler for blockage

If any of the above a faulty then repair, and then

Reprogramme ECU with updated software

Carry our forced regen on DPNR if this occurs then fault is fixed if not replace the DPNR

The bulletin reference is EG-0004T-0110-EN

Share this post


Link to post
Share on other sites

Hi, I have t180 too, and i am noticing a small amount of whitish smoke on acceleration. I recently had the back box replaced with a stainless steel box. Never noticed it before.....although maybe i am only paying attention now after it's been fitted. My EGR is due for a clean, going to see if that helps.

Hoping its not turbo, or injectors. My air filter is new also.

Seem to only notice it for first few miles of a journey though, and maybe only since temperature has dropped.

Share this post


Link to post
Share on other sites

Any progress Andrew on your issue?

Mine is narrowed down to accelerating more heavily than normal, cold or hot engine.

Gonna get it booked in for an investigation ASAP.

Share this post


Link to post
Share on other sites

Well with no help from Toyota I tried a small independent garage just up the road from me after a good look and a drive with me in it he is convinced its one or more injectors.

His opinion is that one or more may be injecting more fuel than needed and its being burned off in the exhaust hence the plume of smoke when driving , so tomorrow its going in and they are taking out the injectors and sending them away for testing and repairing if necessary.

The cost around £30 for testing but up to £100 each for repair and about £100 for labour charges so potentially up to £230 or more and with no guarantee it will finally fix the problem but what choice do I have after spending nearly £800 for something I didn't need (the cat and exhaust ) my wallet is praying this will be the end.

Share this post


Link to post
Share on other sites

Did you ever get the problem fixed? I'm having the same issues

Share this post


Link to post
Share on other sites

Didn’t see this months ago when mine did the same and Toyota couldn’t diagnose. Small garage eventually found the fifth injector was stuffed. It was injecting fuel into the DPF but not igniting, then repeating a few minutes later. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this