Sign in to follow this  
richteex

Rear Lights Help 2007 D4D

Recommended Posts

Wandered if antone of you has come across this issue.

Noticed a few flashes recently as cars go by when its dark.. Checked my rear lights to find the main light on one side not working. Anyway - had a chance to look at it today and pulled out the light cluster on both sides to check.

All other lights are working just not the main one. Anyway sincing pulling the light clusters out - both sides are now out??! Indicators, fog light brake lights etc all fine just the main rear lights.

Ive checked the bulbs swapping them about and they are all fine.

Any ideas?? I dont think its the fuse as I guess all the lights would be out. The rear number plate light is working fine

Any advice would be appreciated.

Thanks

R

Share this post


Link to post
Share on other sites

The rear side lights have the smallest wattage of those you mention so could this be an earth problem,try a temporary earth wire on the cluster

Del

  • Like 1

Share this post


Link to post
Share on other sites

Thanks del but thats way beyond my level of expertise! exepct its a garage job. Thanks anyway

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this