Jump to content
Do Not Sell My Personal Information


Injectors Problem 2.2 D4D


mechmanuk
 Share

Recommended Posts

Avensis 2.2 d4d 2007

Dont know if anyone can help or not but i had my car ino a friends garage to have the head gasket sorted (using water) but ran okay prior.

After they finally got it doene (weeks later) they brought it back but i wasnt happy as it ran ok but was very sluggish like the turbo wasnt working? so they took back.

A week later they told me the injectors are knackered?

I asked them to remove so i could go get em tested, the people who tested them said they was all not spraying but after a while managed to get 3 sorted and i got them back sealed in a bag, at this stage i went and fetched my car back into my garage.

I located another injector and was assured its been tested, i replaced all the injectors in there correct cylinder (I think?) and reprogrammed the 2nd hand one with my solus pro machine.

Got the car running but was really rattly and sounded like it was only running on 2 cylinders then stopped, struggle to get going now?

If an injector works, then doesnt work because its been stood in a damp garage for weeks, and then get working again, can they stop working again? im at a loss now as of the understanding that i can only buy new injectors as recons arnt available?

The car is a mint estate, be ashame to sell on cheap. Any advise apppreciated

Link to comment
Share on other sites


Hi Mechman, personally I wouldn't have thought that standing would cause the injectors to fail, but I do know that if the injectors are not replaced in the same cylinders then they MUST be reprogrammed or exactly the kind of behaviour you described will happen. If you have a gizmo that will program them, I suggest you do all the injectors and be sure that each trim code is matched to the correct cylinder.

Link to comment
Share on other sites

still got the ongoing saga, dont get much time? am i right in saying the cylinders 1 to 4 are from the offside our left as we look at the engine, someone reckons it the other way round 1 nearest gearbox??

Link to comment
Share on other sites


out off the blue ik got 2 error messages on the dash : vsc and parkingbreak. So I brought the car to my toyota dealer. result after putting the car to a diagnostic pc : problems with the injectors. And after physical inspection all 4 where found oxydided due to 'water' in the diesel?! Cost, little less than 3000€. luckly for me the car was still in warranty ( till 25/01/2016!!!).

Car has 85.000 Km and is a couple a day's short to 5 years old.

Link to comment
Share on other sites

  • 2 weeks later...
On 1/22/2016 at 8:41 PM, ghosterror said:

out off the blue ik got 2 error messages on the dash : vsc and parkingbreak. So I brought the car to my toyota dealer. result after putting the car to a diagnostic pc : problems with the injectors. And after physical inspection all 4 where found oxydided due to 'water' in the diesel?! Cost, little less than 3000€. luckly for me the car was still in warranty ( till 25/01/2016!!!).

Car has 85.000 Km and is a couple a day's short to 5 years old.

 

On 1/22/2016 at 11:49 PM, Heidfirst said:

Are you saying Spain because of the hot temperatures?

Last summer on a really hot day (around 26c) I was in a lot of stationary traffic with the A/C on full when I set off the VSC and ABS light came on and stopped on for that whole day, plugged in my OBD reader and I had two injector faults. Cleared the faults and they have never come back. This has happened twice with my car on a hot day.

Link to comment
Share on other sites

8 minutes ago, AlysAvensis said:

 

Are you saying Spain because of the hot temperatures?

 

No, because of the suggestion that it was caused by the fuel & the link that I posted was to somebody else (in Spain) that had posted a day or 2 earlier with similar. It's very, very rare to see that & I was just checking in case they both lived close & there had been e.g. a faulty batch of fuel delivered.

Link to comment
Share on other sites

Just  quick update, ive had all injectors checked and due to them sitting in the cold garage conditions there no longer working so i have to replace. Im waiting now to see if i can find a right off a this will be my cheapest option for these babies. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership