Jump to content
Do Not Sell My Personal Information


Help very Intermittent "Loss of Power" problem


mrbluesky
 Share

Recommended Posts

Wehave a Toyota Rav 4 2008 2.2 litre diesel awd we were on a return journey from Italy climbing up some hills through the alps three months ago and experienced engine stuttering and intermittent loss of power. This lasted for quite a while on our return back to the UK where we felt the engine would cut out completely before we got home, we had no problems at all previously after 87000 miles. We decided to put it down some dirt in the fuel from the fill up we had before our journey, consequently I put some cleaner in with fuel when we returned. Hoping this would help clean the jets etc, we had no problems for three months at all until last week when we experienced the same problem when climbing a hill. However this time it only lasted for the duration of the hill then returned to normal, again there were no warning lights or no indication when driving there could be a problem. Again we had filled up with fuel the day before and it was a sub zero day like the alps. The garage did some diagnostics but could not find a problem they just changed the fuel filter as a advisory. They said they could not resolve the issue unless it is a more reliable problem, we hope to travel to Spain in January but fear it could happen again. Has this happened to anyone else or can anybody help get to the bottom of this mystery?

Link to comment
Share on other sites

I have heard of a similar problem - petrol engine, but it may apply.  The problem was a leaf which had got into the fuel tank, and sometimes blocked the intake

Link to comment
Share on other sites

  • 4 weeks later...

Hi I have a Rav4 2006 2.2 t180 with the same problem. It is intermittent, mainly noticeable in first and second gear but it occurred in third as well. I do mainly short journeys in the town and once a week 60 miles on motorway. I have so far replaced all filters , transmission oil, transfer box oil, gearbox oi,  engine oil, fitted new MAF sensor, cleaned EGR valve and  I only use Shell v power diesel. I had this car for 7 months now with 105k miles on the clock of which I did 6k so far. The problem started few months back and ever since I was trying to find a solution to this. The only thing that brings the power back for few days is when I disconnect the Battery for a few minutes and drive 50 miles at 70 mph on a motorway (I read somewhere that disconnecting the battery will reset the ecu) . The power comes back, but few days later I can feel the slow response to the accelerator again. I cured it once with 2 bottles of Winns diesel injector cleaner added in to a full tank of v-power but this brought it back to life only for two weeks (no issues for 2 weeks) . Now I use one bottle of Winns with every fill up because it does make a positive difference but the issue is still there, some days the car drives and pulls like brand new, but there are times when I feel like setting it on fire and driving off a cliff. There is no engine management light or any other warning light on the dasboard, diagnostic isn't showing any fault codes, I tested the injectors for resistance and the figures were all very similar on all 4 of them.  Another thing I should mention is that the exhaust gives a white/blueish smoke nearly every day. Coolant is bright pink in colour and engine oil is also clean , when I changed the engine oil last time there was no sign of contamination so I believe that the head gasket is okay. I don't know about any warranty replacement being done to the engine as the service history is only partial. So I don't know whether the smoke is related to the lack of power but the car was smoking since I bought it and it was working fine for 5000 miles. I read that SCV's could be behind the lack of power? Anyone has any advice please?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership