estate

Doors won't lock

Recommended Posts

Same problem as I posted earlier this month, can't lock any of the doors, (see copy of post below).

Tried all the same as before and nothing will lock them, also noticed that the Speed sensitive auto lock is also not locking the doors. 

Odds on like before, if I make the trip to the dealership, it will clear itself by the time I get there, but I don't think I have any other option and register it as an intermittent problem.

My 5 year warranty expires in March next year, anyone know if it's covered by the extended warranty?

Anyone had similar problems and found out what's causing it?

(Had to go to the Toyota dealership this morning as the central locking was playing up and I couldn't lock the doors with either the key fob (used both key fobs), door handle sensors, boot switch, toggle switch on drivers door and also the key on the fob itself. However on the way to the garage I continued to try locking the doors with the door toggle switch, no luck until I was about 1/2 mile from the garage and while waiting at the traffic, tried again and it locked). 

Share this post


Link to post
Share on other sites
 

so the mechanical key didn't work either? It's got to be an actuator/solenoid type fault imo.

I would hope that as you have reported the fault within the 5 year warranty that you would be covered.

Share this post


Link to post
Share on other sites

Luckily the fault was apparent when I got it checked out at the dealership today Scott, but unfortunately they are not sure what's causing the problem. It's been booked in for tomorrow to replace the drivers door lock and see if that cures the problem. 

So the only way I can secure the car at the moment, is to individualy move the lock switches on each door,  to the lock position and then lock the drivers door with the key. I Have to do this every time, as when you open the drivers door with the key,  all the other doors unlocked. Hopefully they will fix it tomorrow. 

Share this post


Link to post
Share on other sites

Replacing the drivers door lock didn't fix the problem, so its now booked-in for a more in-depth look at wiring etc next month, that's  when they will be replacing the drivers front door for the crack next to door strap.

Share this post


Link to post
Share on other sites

I had the same problem earlier in the year , it was cured by dealers who reprogramed the car. now today 27th Dec it has done it again , I am also worried as my warranty runs out next year, surely Toyota can find and fix this !!!!

Share this post


Link to post
Share on other sites

Thanks for the information Dave, but before I mention it to the dealership, when its booked in next month would you be so kind to confirm if its exactly the same fault.

The symptoms are:

All doors open normally with key fob and both front door sensors.

The central locking wont lock all doors with the key fob, both front door sensors, drivers door toggle switch and drivers door lock with key and also the auto speed lock stopped working.

The boot can be locked and opened with the switches on the boot door.

Thanks again Dave.

Share this post


Link to post
Share on other sites
13 hours ago, Davmar said:

I had the same problem earlier in the year , it was cured by dealers who reprogramed the car. now today 27th Dec it has done it again , I am also worried as my warranty runs out next year, surely Toyota can find and fix this !!!!

 

11 hours ago, estate said:

Thanks for the information Dave, but before I mention it to the dealership, when its booked in next month would you be so kind to confirm if its exactly the same fault.

The symptoms are:

All doors open normally with key fob and both front door sensors.

The central locking wont lock all doors with the key fob, both front door sensors, drivers door toggle switch and drivers door lock with key and also the auto speed lock stopped working.

The boot can be locked and opened with the switches on the boot door.

Thanks again Dave.

Could it be that it is coincidence that both posters cars are 2012 models or there is a faulty batch of locking ECU's?

Hope both get solved. 

Share this post


Link to post
Share on other sites

Estate, my doors will unlock with fob but not lock, I do not use speed sensor and never have, boot seems to work off sensor. Hope this helps. 😀

Share this post


Link to post
Share on other sites

Thanks for that Dave, sounds like the same symptoms, strange the mechanics at Lindops are not aware of this, if it is the same fault that's causing the problem. I will mention it to them when I book it in next month. As Konrad mentioned, I wonder if it's a rogue batch of ECUs.

Dave my car was manufactured in March 2012, when was yours made? 

Share this post


Link to post
Share on other sites

Estate, my doors will unlock with fob but not lock, I do not use speed sensor and never have, boot seems to work off sensor. Hope this helps. 😀

Share this post


Link to post
Share on other sites

So nearly 2 weeks gone bye since my last visit to get the door locking problem fixed and the problem remained until yesterday, ah! Set-off and I heard the speed auto-lock, locked the doors, tried the door toggle switch and all is working again. It worked all of yesterday and again this morning. It's booked in next week for the drivers door replacement and to sort,  what is now a very intermittent door lock problem. If the fault is not apparent when they check it out, I'm not sure what they can do. 

Share this post


Link to post
Share on other sites

I will never know the route cause of this intermittent problem as the car was involved in an accident while having the drivers door replaced, (see separate post on this) and as a result was an insurance write-off. 

Share this post


Link to post
Share on other sites

I also have the same fault with my Avensis estate 2012 model. Would be interested to know how to cure this problem. 

Share this post


Link to post
Share on other sites
On ‎4‎/‎11‎/‎2019 at 8:20 PM, David Da Cabbie said:

I also have the same fault with my Avensis estate 2012 model. Would be interested to know how to cure this problem. 

Me also, there must be someone out there who has had the same problem and had it fixed.

Share this post


Link to post
Share on other sites

I also had this problem with my 2012 Avensis. The doors wouldn’t lock with the fob but the boot did lock. If I locked manually with the key then unlock worked fine with the fob for the door and the boot. Same issue with the internal locking button on the drivers door, unlock worked but lock didn’t.

Two days ago i started repeatedly pressing unlock, then lock, unlock, then lock..... on the locking button on the drivers door. After about 10 seconds the doors locked. Since then it’s been locking as normal with the key fob.

Its only been two days and the problem might come back but it’s worth a try for anyone else that has this issue.

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...