johalareewi

plugin prius (mk1) clock loses time

Recommended Posts

The clock on my plugin seems to lose time very quickly.  I set it at the end of March when the clocks changed to BST (and noticed it was somewhat slow).  It has lost 2 minutes already.  Do other plugin owners notice the same?

Share this post


Link to post
Share on other sites
 

Yes, mine's not great - I don't know how quickly it goes off but I've had to adjust it several times in the year I've had the car.

Share this post


Link to post
Share on other sites

Both the Gen 2 and Gen 3 Prius, and also the 2015 Auris had what looked like a cheap, and very old design of, digital clock inserted in the dash, with no connection to the rest of the dashboard system.

All three gained noticeably, which used to happen with many early digital clocks.

It was really annoying, as corrections can only be made by advancing the minutes slowly, one at a time.

FWIW, the Gen 4 at last has a decent clock, properly integrated into the dash. After nearly a year, it appears to keep time accurately. I haven't had to readjust it yet, although the time can be adjusted both up and down 

Share this post


Link to post
Share on other sites

The clock on the Gen 3 is integrated into the MFD, it's not a separate device.

Share this post


Link to post
Share on other sites

Happens on my PiP also, a min or so lost every few months.

Share this post


Link to post
Share on other sites

Maybe time travels more slowly in a Prius?

Share this post


Link to post
Share on other sites

Your flux capacitor needs calibrating :blink:

  • Like 1

Share this post


Link to post
Share on other sites

I thought it an odd design decision (especially in the Auris).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now