Jump to content
Do Not Sell My Personal Information


2008 T25 Avensis Wagon 1.8 VVTi Idle issues


dc399uk
 Share

Recommended Posts

Hello
I have a 2008 Avensis Wagon 1.8 petrol, bought in January 2018 with 61k on the clock. Very happy with the car apart from idle issues. 2 problems:

1) The cold idle on start up is very high (about 2100 rpm). Although it comes down fairly quickly, if the car is driven straight away rather than left to warm through for a couple of minutes the engine feels like it is racing.


 2) The idle bounces irratically once warmed up when in neutral or when stopping and putting clutch down. This can range from about 400 to 1100. Last weekend the car stalled about six times at junctions when the idle dropped right down.

The high idle at start has been there since I bought the vehicle. The bouncing idle has only been an issue since the coolant was changed a couple of months ago (along with brake fluid, oil and gearbox oil).

I have had a look in the throttle body and it doesn't seem dirty. I have replaced the MAF sensor but it has made little difference. I have put a new air filter and spark plugs in, although neither looked particularly dirty. No leaks found in air vacuum system. Today I took the car for a diagnostic test - only thing it flagged was that the throttle was only showing 45% open even at 6000 rpm. Therefore could it be the throttle body itself, the TPS or the idle control valve causing the issue (or something else?). The car doesn't hesitate as such when accelerating, although feels a bit lazy.

The idle doesn't bounce all the time (perhaps typically en route to diagnostic test today it behaved impeccably!).

Any thoughts or advice gratefully received!

Thanks.

 

Link to comment
Share on other sites

My previously owned 05 and 55 plate 1.8 vvti's also revved high on cold starts, and the revs varied a bit when idling but not enough for them ever to stall.

Link to comment
Share on other sites

17 hours ago, alan333 said:

My previously owned 05 and 55 plate 1.8 vvti's also revved high on cold starts, and the revs varied a bit when idling but not enough for them ever to stall.

Hi Alan

Thank you for the reply. I think the high idle alone I could probably live with, although still feels too high for too long after start up...? The bouncing idle is more of a concern though, particularly with it cutting out, although hasn't happened since last weekend.

Link to comment
Share on other sites

I had problem 2 and it happened once a week, the high revs when you push the clutch down, I simply cleaned the pcv valve, a normal socket the valve gets rounded, had to order a long socket. Easy job, though I could not screw the valve back in all the way, it does not matter....

You case seems a little more severe, check for a rattle in the valve or try blowing through it either way to test it works.

Link to comment
Share on other sites

On 6/11/2018 at 7:55 PM, m456an said:

I had problem 2 and it happened once a week, the high revs when you push the clutch down, I simply cleaned the pcv valve, a normal socket the valve gets rounded, had to order a long socket. Easy job, though I could not screw the valve back in all the way, it does not matter....

You case seems a little more severe, check for a rattle in the valve or try blowing through it either way to test it works.

Hello. Thank you for the suggestion. I hadn't thought of the PCV valve. Do you know what size socket it needs and I will get one ordered and give it a clean out. It seems to be a bit better at the moment -  still high idle at start but not so uneven when warm and not cutting out.

 

Link to comment
Share on other sites

BERGEN Tools 19mm 1/2 dr 6pt Deep Impact Socket NEW 1332
( 252237797041 )
Add note
ITEM PRICE:
£5.05

I would check the size first with a normal socket and check if you have 1/2 set.

You will also need Teflon tape and you will need to wide it in the correct direction. 

As the valve needs to be screwed in air tight.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership