Jump to content
Do Not Sell My Personal Information


07 verso won't start


Greg o'hagan
 Share

Recommended Posts

Hello fellow toyota fans, can I pick your brains? Clutch in and green light comes on start button. Press button, it goes thru the motions but starter is dead. Took starter out and had it going on the floor with jumpleads. Put it back in, and dead... The fly wire to the button has 12v coming down it!! 12v going to it from Battery too. How is this starter going on the floor but not in the car. Also checked earth's, they seem OK!! What the heck is going on..... Help me!! 

Link to comment
Share on other sites


Hi Greg, welcome to TOC ☺️

How can it go through the motions if the starter is dead? If you mean that it is turning over but not firing then immobiliser?

 

Link to comment
Share on other sites

The steering lock comes off, the fuel pump primes the injection, relays go click under the bonnet. But the starter is dead. Not a sound or a movement. Can't understand it.... Only thing I can think off is the solenoid???  But I had it going on the pavement! I don't know 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership