Jump to content
Do Not Sell My Personal Information


Feels sluggish


Bitch1001
 Share

Recommended Posts

There’s Nothing wrong with it ... it just doesn’t feel as nippy lately ... just feels sluggish ... that’s the only way to describe it 

Any ideas to what it could be 

2015 xcite 14000 miles 

Link to comment
Share on other sites

I can only afford the supermarket value petrol it's not bad got 490 miles out this weeks tank.

Your car might just need a service. My car feels better after a service. 

Link to comment
Share on other sites

A dirty filter, either a lot of dust trapped on the filter, or bits of debri that got in. Its a long shot but worth a look, especially if filter wasn't due for replacement at the last service.

Link to comment
Share on other sites

I opened the the bonnet ....

 

im presuming the filter is under the  black cover thing ...I'm frightened to open it in case I can't get it back on 

it's got silver clips around it ...is that the right thing I should be removing??

Link to comment
Share on other sites

you could try running a different brand of petrol in case the formula for the brand you are using

has changed and your car doesn't like it, this happened to me many many years ago when formula

Shell came to the forecourts it had extra detergents in the mix my car hated it and ran awful

Link to comment
Share on other sites

1 hour ago, Bitch1001 said:

I opened the the bonnet ….im presuming the filter is under the  black cover thing ...I'm frightened to open it in case I can't get it back on it's got silver clips around it ...is that the right thing I should be removing??

That sounds right - if you can unclip them, lift the top off, you may not be able to remove completely as it may have a pipe/s connected. If you lift filter out then remember which way it was to refit. Clips work in reverse to how you unclip them.

Sounds like we all clutching at straws. Could be a partially blocked fuel filter restricting supply of fuel.....but at 14k miles...mmm.... not sure

Link to comment
Share on other sites

1 hour ago, kisbell said:

Give it a good thrashing on the motorway. 

Totally agree. Pop some fuel system cleaner in the tank and take it out for a spirited drive. The 1.0 engine is fine being taken up to 6k rpm every now and again. Well, in my case, more often than not :shock:

Link to comment
Share on other sites

How often do you do motorway trips? Mine has ticked over 16 k mileage in just over a year (yep long trips to work) and has always felt spirited and ready to go. Mixture of motorway and urban driving.

Link to comment
Share on other sites

Just Put a fuel additive in .. I  used Wynn  Formula Gold Petrol Treatment 500ml £16 

 

 Been for a long drive ..... worked the car hard .... did up to  50 in 2nd gear to get revs high , then into 3 rd 

 

I'm normally in 4 th at 30 mph .... felt strange ...but the car was responsive and not crying for a gear change 

 

it's driving a lot better and certainly back to Normal .... 

 

maybe I need to do this more often and it's just a round the town car mostly 

 

thanks for all the help everyone.... much appreciated 

 

 

  • Like 2
Link to comment
Share on other sites

It's surprising what a difference under inflated tyres make to handling (not performance). I hadn't checked mine for a while and all four were about about 15% under pressure. Having pumped them up I felt like I was driving a different car!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership