Sign in to follow this  
Dannny

Instrument panel

Recommended Posts

Got an issue with my instrument cluster, cuts out on pressing accelerator pedal and car stutters.

changed cluster still faulty, changed integration still fault present

any ideas anyone.

 

Share this post


Link to post
Share on other sites

Integration relay sorry left that one out 

Share this post


Link to post
Share on other sites

I had this once. It was a simple resistance build up on the -ive and +ive terminals of the Battery. In the end, the Battery was dead enough so it got replaced anyway.

Share this post


Link to post
Share on other sites

Hi,

 

Why not first try cleaning the Battery terminals and the earth strap to body work   before renewing an expensive Battery ?

A simple voltmeter test on the Battery and alternator would also show up any problem there, plenty of Ytubes showing how to test them with a cheap meter.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Club Hybrid Poll

  • 225 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old