Sign in to follow this  
Mdotg

Crank no start mk1 yaris

Recommended Posts

Hello

So I have a 1999 toyota yaris 1 litre. Never had no issues with it. Few days ago I went to start it and it just cranked over. 

There's spark, can't hear the fuel pump prime. Fuse is ok, relay is ok, swapped with the horn relay and still no difference. Can hear the relay click. Checked for power at the fuel pump connector but not getting anything. 

Gave the fuel pump direct power and can hear it work. I'm pretty much stumped for ideas now. 

Any suggestions will be appreciated 

Thanks 

Share this post


Link to post
Share on other sites

I thought the pump was in the fuel tank and inaccessible?

Share this post


Link to post
Share on other sites

There's access under the rear seats. It's all sorted now 😊

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Club Hybrid Poll

  • 322 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old