AdeleLiverpool

Touch 2 and other failures at 55-70 mph auris touring hybrid 2018

Recommended Posts

Bought a new Auris Touring Hybrid estate 68 plate in September from Johnson in Liverpool. Great guys but the car has some major issues and is brand new. 5 weeks in and driving on the motorway at 60mph approx audio output failed, then radio connection followed by sat nav, the Touch 2 screen shut down and rebooting spontaneously and front camera froze on a road side speed sign for about an hour. The system shut down and rebooted constantly thereafter. When I finished the drive, the rear camera froze later on when I was reversing to park and the Touch 2 wouldn't recognise my iPhone, still shutting down and rebooting. Also noticed that the front and rear collision sensors where occasionally going off and showing the wrong sensor also for closeness of objects, and cruise control didn't seem to kick in properly.

Took it back to Johnson and they initially thought it was an update needed but then after diagnostic check they recognised the car needed a new Sat Nav  system and Audio System/Media Centre installed as the one in place was deemed faulty. So I'd been sold a fault car from the offset by Toyota. Not happy about that but I thought ok I'll see what happens with this repair. This was around  day 40 of purchase.

Got the car back 3 days ago (Sunday) and driving around town at about 30 mph the car seemed fine.

Today however, I was on a journey to Wales and as soon as I got up to around 60mph on the motorway the Media Centre, Cameras and Sat Navigation system failed again; same issues but this time in addition rear camera kept on coming up when I wasn't in reverse and my phone was not recognised. Constant shutting down and rebooting of the system.

I've taken the car back in today to Johnson who again are are doing a diagnostic test tomorrow and I'm waiting on the results.

The Service Team have told me that these issues have nothing to do with the safety of the car whilst driving at speed. I'm not convinced and definately doen't feel safe in the car when the electrics are freezing and shutting down. Worried about having a crash as a result of a fault car.

Has anyone else had these issues?

Surely as it's a new car 19th September 2018 and the initial issues are still present and seemingly unresolved, should Toyota be considering giving me a replacement new car? I bought on a 3 year purchase plan.

 

Share this post


Link to post
Share on other sites
 

The contract will be between yourself and the dealer - not Toyota - so in the first instance it is the dealer who should be rectifying things. Have you approached the dealer principal regarding the issues and possible replacement?

Share this post


Link to post
Share on other sites
16 hours ago, AdeleLiverpool said:

Has anyone else had these issues?

Hi Adele, welcome to TOC 🙂

Whilst over the years there have been various complaints raised here about Touch 2  as a system & similarly some about the various driving aids I can't recall anything like yours. Sorry, I know that it doesn't really help when it is you that is experiencing the issues but yours does seem to be an unique or incredibly rare problem.

Share this post


Link to post
Share on other sites

Give the dealership three strikes to repair. If these symptoms persist I would be inclined to return the car as not fit for purpose. 

Share this post


Link to post
Share on other sites

i'm sure johnsons will sort the issue out for you they seem to be a decent

company to deal with ,we use johnson wirral for our toyota and i used

johnsons lexus ( next to johnson toyota) liverpool for servicing ,i have also

bought 2 cars from them, so yes i'm happy with the service we have received.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now