Taxi100

Parking brake problem

Recommended Posts

Strange problem , my parking brake warning comes on after I've done a hill start . after I switch off the engine and restart the warning light goes off . any ideas , its a 2008 t27 model 

Share this post


Link to post
Share on other sites
 

Hi John, welcome to TOC 🙂

Please confirm what model as afaik all T27s are 2009>.

Share this post


Link to post
Share on other sites

Sorry its a 2.0 d4d ,must be 2009 . the problem only seems to occur when I have passengers and luggage in the back 

Share this post


Link to post
Share on other sites

Just realised its a t4 model 

Share this post


Link to post
Share on other sites

1 easy way to solve the confusion - manual handbrake or epb?

Share this post


Link to post
Share on other sites

Brake fluid level might be a bit low which would put on the light 

Share this post


Link to post
Share on other sites

Thanks taxi501 that would make sense as like I said it only happens when stopped on an incline .I'll look into that now 

Share this post


Link to post
Share on other sites

Well I topped the brake fluid up ,wasn't much needed and it seems to have done the trick , thank you so much 

Share this post


Link to post
Share on other sites

Bear in mind that when brake pads wear the system uses more brake fluid to push/hold the pistons out further.  ie there's a fair chance your brakes are getting thin.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...