ANTHONY4

Avensis T3-S D-4D no power no start black smoke

Recommended Posts

Hi i have a Avensis T3-S D-4D it turns over with key but will not start and also will not jump start but it will bump on a hill. When engine running it drives ok until it warms up then it loses power then power comes back for a bit then back to no power. But i have noticed that when driving with no power black smoke comes out of the exhaust then when power comes back it releases a lot of black smoke at once then runs ok until loses power again.Is there anything i could check or do myself before i take it to a garage any advice please

Share this post


Link to post
Share on other sites
 

The part of no power and black smoke sounds like a classic case of blocked EGR valve. Either clean it yourself or have a garage so it, but it has to be done properly — soak it in carb cleaner and go at it with a toothbrush everywhere, also rotate the valve stem to clean it from all sides.

While I can't guarantee it will cure the starting troubles, it probably is the cause of power and smoke issues when car is warmed up. Clean the EGR and go from there.

Share this post


Link to post
Share on other sites

Cheers will try,will let you how it goes, Also someone told me to check the temp sensor

 

Share this post


Link to post
Share on other sites

Agree, sounds like EGR needs cleaning

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...