Recommended Posts

Hi again everyone, Wife's Rav 4VX 5 door auto is consuming fuel like its a penny a gallon, I know they are not good on fuel and I was wondering if there is a more fuel efficient engine swap/gearbox and loom, the auto has to stay, she is in love with the beast, the four wheeled one that is, so if you have any suggestions and ideas I would be very interested.

Share this post


Link to post
Share on other sites
 

What figure are you getting on the average read out David and does the engine get hot for long, or is it used just for local runs

It also begs the question were you led to believe it would be economical and have a higher MPG

Del

Share this post


Link to post
Share on other sites
On ‎1‎/‎24‎/‎2019 at 8:06 PM, crofter said:

What figure are you getting on the average read out David and does the engine get hot for long, or is it used just for local runs

It also begs the question were you led to believe it would be economical and have a higher MPG

Del

Hi Del, my apologies for not getting back sooner, it is only giving 20 mpg, engine temp is always normal but their seems to be no lower end exceleration, feel like in trying to pull away in 2nd or even 3rd and with the harsh clunking going into reverse, I have searched you tube and many, many people are saying it is the resistors on the ECU board are loosing their solder joints due to heat running through them, so, I took the ECU out and resoldered all of the R10s, R330s and 820s, I then feeling really pleased to have done that, put it back in the car just to get no change what so ever.

 

Share this post


Link to post
Share on other sites

Moved to the Rav4 club

Share this post


Link to post
Share on other sites

I live in Jersey, so its pretty well all local stop/go stuff - five miles is a long run!  I get about 22 in winter and 25 in summer, but as the miles/month are very limited, it doesn't make a bit dent in the wallet.

You haven't mentioned service history, but things I'd check are spark plugs and air filter.  Mine is pretty sprightly if the throttle is booted, so yours could be out of tune.

As for as the clonking in reverse - is the transmission fluid up to the mark, and when was it last changed?

Share this post


Link to post
Share on other sites

Further thought...

If you think it is not using 1st or maybe 2nd, try driving off from rest with the transmission shifter in L, move it to 2 at about 2500 rpm, then D (with the overdrive to off), then overdrive on.  Did you get four shifts as evidenced by the rev counter?  If not, that would definitely point to a transmission problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...