Sign in to follow this  
Arnoldlayne

Surf not starting!

Recommended Posts

I was hoping you guys might be able to help. My parents have an import Toyota Surf 1994 and up until recently the Clifford Concept 300 alarm that was fitted in it caused no problems, then the remote for the central locking worked, but the immobiliser stop working. In other words there was no response at all.  Also, the light on the dash would not illuminate.  

My parents changed the batteries in the remote in an effort to rectify the situation but the immobiliser would still not allow the vehicle to start. Following this they contacted an 'alarm specialist' who came out to inspect the vehicle. He said that the alarm has never worked and disabled it, unfortunately the vehicle Battery was low because they had tried to start it so many times. The specialist told them to charge the Battery overnight, use Easy Start and it should start....it didn't.

Finally a mechanic came out to have a look but couldn't come up with any answers as to why the vehicle wouldn't start. Has anyone else experience similar problems?

Thanks in advance. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Club Hybrid Poll

  • 64 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old