Sign in to follow this  
old ian

No throttle response or dashboard functions

Recommended Posts

have an 08 avensis, one of the grandchildren left interior light on, car would not start, charged the Battery , now starts but no throttle response or dashboard functions, car moves but very slow only, any ideas

Share this post


Link to post
Share on other sites

Disconnect the Battery for 10 minutes, reconnect the Battery, start the car, let it idle for 10 minutes, then try to drive it.

Share this post


Link to post
Share on other sites

Topic title edited.

Moved to the Avensis club.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Club Hybrid Poll

  • 322 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old