fixitphil

1998 1800 avensis rough running fix

Recommended Posts

Today had a pleasent result. For the last year or more car has not been as smooth as when first bought 18 short years ago. Poor start up/ warm up tick over and when warmed up normal tickover oscillating between 700rpm to shudder low revs to pickup again. Yesterday engine warning light on so had to bite the bullet and sort the fault. Long story short, the original vacuum link from MAP sensor to manifold (yes MAP sensor) looked fine till I disconnnected it and found extreme fatigue failure cracks and also slack fit to the device spiggot.  New pipe ty wrapped on superb smooth running motor.  I had couple of weeks before checked and cleaned most of the snap on electrical connectors just in case corrosion effects.  Non present.

Cost of fix absolutely nowt,   the perfect price.  I am now content to drive through heavy traffic again.

Best of luck one happy Fixitphil

 

  • Like 3

Share this post


Link to post
Share on other sites
 

Probably a good idea to check the other vacuum lines in the engine bay. Nice results.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...