Sign in to follow this  
jackrmee

Engine idling high 2004 Roadster

Recommended Posts

Hi,
I know this is very difficult to diagnose, but anyone have any ideas on best place to start?
She's been sitting in the garage for a good while, so I gave her a full service (filters, Oil and plugs). She's running ok, but is idling around 1500-1700 revs. Is this too high?

I've also noticed the throttle pedal is sticking slightly. When I jump in for the first time of the day, I need to opush my foot down hard to release it, as it seems to be stuck somewhere. Once it's loose, it's fine for the day. Not sure if it might be linked.
Engine management light is also on, but has been like that for ages, as the power steeering pump was gone. I fixed it, but didn;t turn the light off, so may be still on for that, as I don't have OBD tool to check or turn it off. If anyone can recommend me an OBD tool I will get one of them and have a look.

Thanks in advance 🙂

Share this post


Link to post
Share on other sites
 

Posted (edited)

Old models won't support any fancy features on bluetooth OBDll So I recommend that orange one with a cable 

My avensis also starts up 1500 but steadies ~ 700 when wormed up 

Disconnected Battery (negative only (should clear the code)

Better wait for code reader 

Costs ~ £10 and It works 5 years now 

You might want to buy a fancy one 

s-l400.jpg

Edited by Amatér
Additional stuff

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this