Sign in to follow this  
N_A

Slow acceleration problems

Recommended Posts

Hello everyone! I bought a used 2012 iQ from the Toyota dealership with 90K miles. Since the first day I noticed that sometimes the gas pedal is not responding immediately. The issue gets much worse whenever the AC is running. Sometimes it takes up to 3 seconds to even realize I pressed the gas. It really feels unsafe to drive. My friend with the same iQ drove mine and said that his doesn't act the same way. I did some maintenance trying to fix the problem but it didn't work. Here is what I did so far:

-CVT fluid change
-new spark plugs
-cleaned MAF sensor
-cleaned throttle body
-fresh motor Oil
-cleaned accelerator pedal connections
-ECU reset
-Idle reset relearn procedure

Any ideas?

Share this post


Link to post
Share on other sites

When did you buy the car and what warranty did it come with?

Share this post


Link to post
Share on other sites
On 7/13/2019 at 3:31 PM, N_A said:

Hello everyone! I bought a used 2012 iQ from the Toyota dealership with 90K miles. Since the first day I noticed that sometimes the gas pedal is not responding immediately. The issue gets much worse whenever the AC is running. Sometimes it takes up to 3 seconds to even realize I pressed the gas. It really feels unsafe to drive. My friend with the same iQ drove mine and said that his doesn't act the same way. I did some maintenance trying to fix the problem but it didn't work. Here is what I did so far:

-CVT fluid change
-new spark plugs
-cleaned MAF sensor
-cleaned throttle body
-fresh motor oil
-cleaned accelerator pedal connections
-ECU reset
-Idle reset relearn procedure

Any ideas?

Greetings,

Did car behaved the same way during test drive or it started to behave after you drove it from dealer?

Share this post


Link to post
Share on other sites
6 hours ago, lovec1990 said:

Greetings,

Did car behaved the same way during test drive or it started to behave after you drove it from dealer?

I bought it without any warranty. The car started behaving this way right after I bought it. At the beginning it wasn't really an issue but then it started getting more noticeable. I feel like it got a little worse during the past 9 months.

Failing CVT? 

Share this post


Link to post
Share on other sites

1.0 litre or 1.33?

Share this post


Link to post
Share on other sites
1 hour ago, FROSTYBALLS said:

1.0 litre or 1.33?

1.33

Share this post


Link to post
Share on other sites

Have you tried a diagnostic on it?

Share this post


Link to post
Share on other sites
On 7/13/2019 at 3:31 PM, N_A said:

Hello everyone! I bought a used 2012 iQ from the Toyota dealership with 90K miles. Since the first day I noticed that sometimes the gas pedal is not responding immediately. The issue gets much worse whenever the AC is running. Sometimes it takes up to 3 seconds to even realize I pressed the gas. It really feels unsafe to drive. My friend with the same iQ drove mine and said that his doesn't act the same way. I did some maintenance trying to fix the problem but it didn't work. Here is what I did so far:

-CVT fluid change
-new spark plugs
-cleaned MAF sensor
-cleaned throttle body
-fresh motor oil
-cleaned accelerator pedal connections
-ECU reset
-Idle reset relearn procedure

Any ideas?

EGR !

Share this post


Link to post
Share on other sites

When you say it takes a few seconds to respond does it do anything, do the revs increase?

If the revs don't climb then maybe the accelerator potentiometer or throttle position sensor on the pedal itself is faulty.

Might be worth a trip to a Toyota dealer to get it on the computer and see if any faults are recorded.

 

Craig.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this