Sign in to follow this  
Hybridjunky

Any idea what this says anyone?

Recommended Posts

Just bought my first Estima Hybrid and noticed that just before Ready is displayed, it beeps and this message is displayed.

I had the Lexus RX400 hybrid where it displayed a similar message and turned out that the petrol filling cap hadn't been tightened fully.

I am hoping this is something trivial like that!

Any input will be appreciated.

Cheers

IMG_20190822_102837.jpg

Share this post


Link to post
Share on other sites

Ok so according to my Japanese friend it says initial check but if anyone knows otherwise please share.

Cheers

Share this post


Link to post
Share on other sites

 google lens app

cannot belive you have jap car but you are not using google lens with translate function on your smartphone!??

Share this post


Link to post
Share on other sites

Google translate on your phone does the same thing, no need to install additional stuff on your phone.

Open it, adjust the language, click on camera icon, take a photo, it recognizes the text and auto translates, or you can just swipe your finger on the part of text you want to translate.

Share this post


Link to post
Share on other sites

Thanks for that suggestion furtula. I've already done that and got the same answer "initial check". I would just like to know if other Estima hybrid owners get the same message at startup?!

Cheers

Share this post


Link to post
Share on other sites

Sorry to break it to you: This lights up when there's a problem with Battery traction. In my case it meant I had to replace the high voltage Battery at a cost of £2,250. The warning message normally comes in conjunction to others, such as stability control, abs, brakes and engine. It's one of the signs of Battery end of life. I don't know if there are any other reasons why you would get that. Has you fuel consumption gone up? Does the Battery charge go from low to high and viceversa quite quickly? If so, again symptoms of a tired main Battery

Sorry, I wish I could have said something else.

Share this post


Link to post
Share on other sites

Hi Javier

I've now been driving the car for a while and haven't had any issues with the car and no other lights have ever come up. Also just to repeat that this light only comes up for a few seconds when the car is first switched on. I have been getting pretty good mpg as well and the main Battery appears to be getting charged and discharged as it should because I keep an eye on it with the hybrid assistant app. Perhaps if this message comes up when you are driving the car then it means trouble and not when it is just doing the initial check on startup.

What's more, I had a look at a few other hybrid estimas of same model and they all display the same message at startup.

Cheers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this