Jump to content
Do Not Sell My Personal Information


Rav4 2008 2.2 d4d d-cat wont rev after a couple og minutes.


Henrik (Denmark)
 Share

Recommended Posts

13 hours ago, furtula said:

You just need an adapter cable, can get it from websites like ebay and alike, costs 10-15 GBP, just search for Toyota techstream adapter cable.

Most of them come with with a small disc with the software.

Downside is that it works out of the box on windows xp only, on newer ones you need to do some workarounds, however some people reported using windows XP in a virtual box and that it worked fine, and yeah, you also need a laptop for it, but as you can see in the topic, it's a powerful troubleshooting tool.

 

Thanks for reply.

I have ordered one now. I have a workshop laptop with Windows xp so that is perfect. I really regret spending 300 GPP om another tester. But that is life. I am so excited to get it and see ud that can shed some light over this annoying error😁

Link to comment
Share on other sites

  • 2 weeks later...

More help is needed. I have now received the cable and a disc with software. Everything is fine except for the key i got from the dealer is not working. What do i do? I have v. 14.

Thanks again.

Regards Henrik

Link to comment
Share on other sites

What key from the dealer? Did you buy the license to use the software for some limited time, or some other key?

From what i know, the cables usually  get shipped with pirated, though working software.

Link to comment
Share on other sites

58 minutes ago, furtula said:

What key from the dealer? Did you buy the license to use the software for some limited time, or some other key?

From what i know, the cables usually  get shipped with pirated, though working software.

I had to send the product number to the dealer and then get a key. It was described in the disc, so could not see it before arrival. So now i need some pirated software, but i can not find any.

Link to comment
Share on other sites

Something is off there, since the license according to Toyota website differs quite a lot, and same as toyota tech manuals it's bought on limited subscription basis.

I don't know what kind of license you bought from a dealer, but if you did, you should demand they fix it.

In the meanwhile you can download a cracked version online, while it's getting fixed, pm me if you have problems getting it.

https://www.toyota-tech.eu/GTS/Wizard/Step6.aspx

image.thumb.png.0cd635ee5703b3238fedd2f0489d5d63.png

Link to comment
Share on other sites

Thanks for your help. The seller will fix it with teamviewer. In the meanwhile i have had the injectors tested and they are all faulty. 3 of them is leaking a lot, the last one has a shortcut inside in the electrics. So probably where the fault is. I have been scouting online for a new set and the cheapest i can find are at commonraildiesels.com at 200 GBP each. Does anyone have any experiences with them? I am wondering how they can sell them at almost half price of everybody else. I freakin' love this forum! Lots of replys and competent people!

Thanks again 🙂

Link to comment
Share on other sites

1 hour ago, Henrik (Denmark) said:

Thanks for your help. The seller will fix it with teamviewer. In the meanwhile i have had the injectors tested and they are all faulty. 3 of them is leaking a lot, the last one has a shortcut inside in the electrics. So probably where the fault is. I have been scouting online for a new set and the cheapest i can find are at commonraildiesels.com at 200 GBP each. Does anyone have any experiences with them? I am wondering how they can sell them at almost half price of everybody else. I freakin' love this forum! Lots of replys and competent people!

Thanks again 🙂

Fix it via teamviewer? That does not sound like a dealer bought license to me, and if it's not, i would not give access to anyone as it's possible to backdoor the PC even if it's all shown on screen.

I can send you a copy of my Techstream if you wish, just pm me.

If you install injectors yourself, it's necessary to code them to the car using techstream.

I checked that website and my prices  differ a lot from what you wrote, injectors for 2AD-FTV(FHD) are 85 to 99 GBP, some say reconditioned, some which are cheaper, dont say reconditioned.

 

Link to comment
Share on other sites

57 minutes ago, furtula said:

Fix it via teamviewer? That does not sound like a dealer bought license to me, and if it's not, i would not give access to anyone as it's possible to backdoor the PC even if it's all shown on screen.

I can send you a copy of my Techstream if you wish, just pm me.

If you install injectors yourself, it's necessary to code them to the car using techstream.

I checked that website and my prices  differ a lot from what you wrote, injectors for 2AD-FTV(FHD) are 85 to 99 GBP, some say reconditioned, some which are cheaper, dont say reconditioned.

 

It a workshop laptop so it is limited what her can do with it. He is going to help with some drivers that are teasing me too.

The engine code is 2ad-fhv so they are expensive. What can you get them for? Not reconditioned. 

Link to comment
Share on other sites

3 hours ago, Henrik (Denmark) said:

It a workshop laptop so it is limited what her can do with it. He is going to help with some drivers that are teasing me too.

The engine code is 2ad-fhv so they are expensive. What can you get them for? Not reconditioned. 

Turns out those are all 2ad-ftv, so for yours i got the same price as you. 

Link to comment
Share on other sites

  • 1 month later...

Hi guys.

After some waiting time i am back. The car is still not running.

I had to buy new injectors from a toyota dealer. I have programmed them and everything so the fault is not there. My techstream is up and running so i have detached a couple of photos of the live data in idle. Can anyone see anything that are not looking how it should? Only thing i still see is the exhaust temperatures at 750 degrees. The 5. injector is not connected at all (Nor electric or fuel line). If i disconnect the two sensors they will be at 0 degrees but the fault still occurs. Do i need a new ECU or what am i going to do next? Toyota had it for 2 weeks and they gave up, with the reason that it could be the tuning. The car has been running fine for several years so i really do not believe that is the issue.

Thanks again for your help.

Kind regards Henrik Hansen

data1.jpg

data2.png

Link to comment
Share on other sites

  • 1 year later...
On 11/24/2019 at 4:49 PM, Henrik (Denmark) said:

Hi guys.

After some waiting time i am back. The car is still not running.

I had to buy new injectors from a toyota dealer. I have programmed them and everything so the fault is not there. My techstream is up and running so i have detached a couple of photos of the live data in idle. Can anyone see anything that are not looking how it should? Only thing i still see is the exhaust temperatures at 750 degrees. The 5. injector is not connected at all (Nor electric or fuel line). If i disconnect the two sensors they will be at 0 degrees but the fault still occurs. Do i need a new ECU or what am i going to do next? Toyota had it for 2 weeks and they gave up, with the reason that it could be the tuning. The car has been running fine for several years so i really do not believe that is the issue.

Thanks again for your help.

Kind regards Henrik Hansen

data1.jpg

data2.png

Hi !

Is the problem solved or not?

Ihave the same problem with my car

Link to comment
Share on other sites

  • 2 months later...

Hello!

I have a Rav4 same engine.

The same issue,the car wot rev over 3k,but if turned off stay off about 10 sec it starts and all is OK about 1min then the problem is back again.

Just like your problem from this topic:

https://www.toyotaownersclub.com/forums/topic/189744-rav4-2008-22-d4d-d-cat-wont-rev-after-a-couple-og-minutes/page/2/#comments

Mine is the same case Decat and no DPF With remap. No codes,all sensors i can remember are replaced.

Did you find the problem or solution.

Please!

I`m running out of ideas.

Thanks in advance!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership