Sign in to follow this  
JamesCStockholm

2007 Avensis 2.4 high oil consumption

Recommended Posts

Have recently relocated to Sweden and bought a 2007 facelift t250 2.4 auto estate with 198k km on the clock. The car seems to be consuming huge amounts of Oil, had the Oil changed in December and it’s already down to the minimum on the dipstick after only doing about 1000 miles. I read that there were issues with the AZ engine consuming Oil but thought they were confined to US vehicles. Has anyone encountered a similar problem? I realise they’re a pretty rare care in the U.K as they weren’t on sale long. 
 

Hope someone has an answer, I’m spending a fortune on Oil!

Thanks in advance 

Share this post


Link to post
Share on other sites

Sorry to hear the sad news. My friend has exactly the same issue. Avensis 2.4 high oil consumption. I think it is a common issue on these models.

Share this post


Link to post
Share on other sites

Yes it happens to some of the cars, it´s usually the pistonrings that get stuck in piston grooves. 
There is some cheap "bodge" type of "repairs"  you could try, but it´s on your own risk and not a proper repair. 

Google on "SAAB wd40 metoden"  to read up on it

I´m actually just about to try that "repair" on my sisters 2,0 T25 MY04 for the same issue

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this