Sign in to follow this  
Mike2777

Slight stutter/ judder

Recommended Posts

Hi guys, new owner here. Loving the car apart from one thing and its driving me mad.

I purchased a 2009 estima hybrid "ahr20" model. When accelerating and getting to the speed limit ie... 30 40 70 etc, I find the car has a slight stutter or judder, I've had someone in the car that confirmed they could feel it to, but pinpointing when its actually going to do it is difficult. Just kind of takes the smoothness out of the otherwise lovely drive. There are no fault codes stored, I've given it a service, plugs, filters and Oil. I've purchased (and waiting for) some transmission fluid as I thought changing it wouldn't do any harm and may help. Not sure if its engine or drivetrain related. Has anyone any idea what it could be ? I'm not clued up on common problems etc, but I'm competent enough with the spanners. So any guidance would be very welcome. Thanks in advance guys, fingers crossed someone can point me in the right direction.

Share this post


Link to post
Share on other sites
On 6/29/2020 at 12:30 AM, Mike2777 said:

Hi guys, new owner here. Loving the car apart from one thing and its driving me mad.

I purchased a 2009 estima hybrid "ahr20" model. When accelerating and getting to the speed limit ie... 30 40 70 etc, I find the car has a slight stutter or judder, I've had someone in the car that confirmed they could feel it to, but pinpointing when its actually going to do it is difficult. Just kind of takes the smoothness out of the otherwise lovely drive. There are no fault codes stored, I've given it a service, plugs, filters and oil. I've purchased (and waiting for) some transmission fluid as I thought changing it wouldn't do any harm and may help. Not sure if its engine or drivetrain related. Has anyone any idea what it could be ? I'm not clued up on common problems etc, but I'm competent enough with the spanners. So any guidance would be very welcome. Thanks in advance guys, fingers crossed someone can point me in the right direction.

I would check all tyres for balancing, also fuel filter.

Share this post


Link to post
Share on other sites

Had a similar thing on a 4x4 some years ago...though it was more a judder than a stutter...turned out one of the tyres was out of round.!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this